aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python23
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /lang/python23
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'lang/python23')
-rw-r--r--lang/python23/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python23/Makefile b/lang/python23/Makefile
index ae0a12bc3809..5dfd1913ecd1 100644
--- a/lang/python23/Makefile
+++ b/lang/python23/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-fpectl
CONFIGURE_ENV= OPT="${CFLAGS}"
MAKE_ENV= VPATH="${WRKSRC}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
INSTALL_TARGET= altinstall
MAN1= ${PYTHON_VERSION}.1
@@ -111,7 +111,7 @@ pre-patch:
's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
${WRKSRC}/Lib/pydoc.py
${REINPLACE_CMD} -e \
- 's|^\(prefixes = .*\)\]$$|\1, "${X11BASE}"]|g' \
+ 's|^\(prefixes = .*\)\]$$|\1, "${LOCALBASE}"]|g' \
${WRKSRC}/Lib/site.py
.for ver in 6 7 8
${MKDIR} ${WRKSRC}/Lib/plat-freebsd${ver}