aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python24
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2005-06-19 19:34:56 +0800
committerperky <perky@FreeBSD.org>2005-06-19 19:34:56 +0800
commit3927eeb56f0099ecebd5c9dde8289092fe15ea1d (patch)
tree8432d7ddda57883aead909edc8f1b54154222083 /lang/python24
parent26c9d41f198650e2fab898431da46436f1281586 (diff)
downloadfreebsd-ports-gnome-3927eeb56f0099ecebd5c9dde8289092fe15ea1d.tar.gz
freebsd-ports-gnome-3927eeb56f0099ecebd5c9dde8289092fe15ea1d.tar.zst
freebsd-ports-gnome-3927eeb56f0099ecebd5c9dde8289092fe15ea1d.zip
- Disable "fpectl" base module on non-i386 platforms to fix build
on the recent -CURRENT i386 base. [1] - Fix package build on NO_NIS base. [2] PR: 81806 [1] Submitted by: Li-Lun Wang (Leland Wang) <llwang@infor.org> [1], ache [2]
Diffstat (limited to 'lang/python24')
-rw-r--r--lang/python24/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/python24/Makefile b/lang/python24/Makefile
index 28f2516d69e9..be1c1279193f 100644
--- a/lang/python24/Makefile
+++ b/lang/python24/Makefile
@@ -33,6 +33,7 @@ PYTHON_NO_DEPENDS= yes
USE_REINPLACE= yes
SHARED_WRKSRC= ${WRKSRC}/build.shared
+PLIST= ${WRKDIR}/pkg-plist
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
@@ -127,9 +128,8 @@ pre-patch:
${WRKSRC}/Lib/site.py
${MKDIR} ${WRKSRC}/Lib/plat-freebsd6
${CP} ${WRKSRC}/Lib/plat-freebsd5/regen ${WRKSRC}/Lib/plat-freebsd6/
-.if defined(WITH_FPECTL)
+.if defined(WITH_FPECTL) && ${ARCH} == i386
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
- ${REINPLACE_CMD} 's,fpreset,fpset,g' ${WRKSRC}/Modules/fpectlmodule.c
.endif
post-configure:
@@ -157,6 +157,11 @@ post-build:
${SETENV} ${MAKE_ENV} ${MAKE} lib${PYTHON_VERSION}.so python; \
${LN} -f lib${PYTHON_VERSION}.so lib${PYTHON_VERSION}.so.1; \
${LN} -f python ${PYTHON_VERSION:S/thon/thon-shared/}
+.if !exists(/usr/bin/rpcgen) # the world with NO_NIS
+ ${GREP} -v 'nis.so$$' ${PKGDIR}/pkg-plist > ${PLIST}
+.else
+ ${CP} ${PKGDIR}/pkg-plist ${PLIST}
+.endif
pre-su-install:
.for platform in ${PLATFORMS}