aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python26
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2009-07-14 17:29:03 +0800
committerlwhsu <lwhsu@FreeBSD.org>2009-07-14 17:29:03 +0800
commitb2d633c8b15e60793d42807c27c36ce8d5f6f350 (patch)
tree63a8e4e920158ba8bfcdef7ea4cedd5b38ec60c6 /lang/python26
parent0f2dc71f6a774d010910fdee4612b9bcbe55cf11 (diff)
downloadfreebsd-ports-gnome-b2d633c8b15e60793d42807c27c36ce8d5f6f350.tar.gz
freebsd-ports-gnome-b2d633c8b15e60793d42807c27c36ce8d5f6f350.tar.zst
freebsd-ports-gnome-b2d633c8b15e60793d42807c27c36ce8d5f6f350.zip
- Ask the first Python installed to install the bin/python link,
and be the default Python version PR: ports/109550 Submitted by: David Yeske <dyeske AT yahoo.com> Obtained from: tmclaugh
Diffstat (limited to 'lang/python26')
-rw-r--r--lang/python26/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index d07b0d7cd1cd..471c86118f27 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python26
PORTVERSION= 2.6.2
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -74,7 +75,7 @@ SEM_MSG= "@comment "
SUB_FILES= pkg-message
SUB_LIST= SEM=${SEM_MSG}
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
+.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION} || !exists(${LOCALBASE}/bin/python)
MLINKS= ${PYTHON_VERSION}.1 python.1
PLIST_SUB+= IF_DEFAULT=""
.else
@@ -240,7 +241,7 @@ post-install:
${INSTALL_MAN} ${PYTHON_WRKSRC}/Misc/python.man \
${MANPREFIX}/man/man1/${PYTHON_VERSION}.1
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
+.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION} || !exists(${LOCALBASE}/bin/python)
for f in ${BIN_FILES}; do \
TARGET=`${ECHO_CMD} $$f | ${SED} -E ${BINLINKS_SUB}`; \
cd ${PREFIX}/bin && ${LN} -f $$TARGET $$f; \