aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python27
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-31 18:13:55 +0800
committermiwi <miwi@FreeBSD.org>2012-05-31 18:13:55 +0800
commit0f0ff6057a41e54afef2d78cd01af5ce4c95810b (patch)
treeecf9de11ccbc15564ea375b7cab6d346be571e2a /lang/python27
parent45440dbafa4ce541abf3573dc2bc13a122d485e9 (diff)
downloadfreebsd-ports-gnome-0f0ff6057a41e54afef2d78cd01af5ce4c95810b.tar.gz
freebsd-ports-gnome-0f0ff6057a41e54afef2d78cd01af5ce4c95810b.tar.zst
freebsd-ports-gnome-0f0ff6057a41e54afef2d78cd01af5ce4c95810b.zip
- Correct PYMALLOC logic (that fix the build of devel/gobject-introspection)
- Remove old OPTION layout from py32 - Bump PORTREVISON
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index cf57c895186e..94ed7116127a 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python27
PORTVERSION= 2.7.3
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -50,10 +51,10 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES
-OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
+OPTIONS_DEFAULT= THREADS UCS2 PYMALLOC IPV6
OPTIONS_SINGLE= UCS
-OPTIONS_SINGLE_UCS= UCS4 UCS2
+OPTIONS_SINGLE_UCS= UCS2 UCS4
.include <bsd.port.pre.mk>
@@ -106,7 +107,7 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --enable-unicode=ucs2
.endif
-.if ${PORT_OPTIONS:MPYMALLOC}
+.if empty(PORT_OPTIONS:MPYMALLOC)
CONFIGURE_ARGS+= --without-pymalloc
.endif