aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python27
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-08-18 03:10:59 +0800
committermva <mva@FreeBSD.org>2013-08-18 03:10:59 +0800
commit120b0d35293d8e00d39d7ad2ad7d574983111671 (patch)
tree5fb4dff170d638784a5c9228ee0855dbe6de4641 /lang/python27
parente67297db9d1ad0fca3185a3d0c121af1e8ec2e24 (diff)
downloadfreebsd-ports-gnome-120b0d35293d8e00d39d7ad2ad7d574983111671.tar.gz
freebsd-ports-gnome-120b0d35293d8e00d39d7ad2ad7d574983111671.tar.zst
freebsd-ports-gnome-120b0d35293d8e00d39d7ad2ad7d574983111671.zip
- Move the symlink magic for the default python version into lang/python
and lang/python2 and lang/python3. This change brings us closer to the goal of making Python ports usable with different Python versions at the same time. - Add a new lang/python2 port to handle the symlinks for bin/python2, bin/idle2, bin/pydoc2 and so on. - Add a new lang/python3 port to handle the symlinks for bin/python3, bin/idle3, bin/pydoc3 and so on. - Bump the PORTREVISION on all lang/python* ports.
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile23
-rw-r--r--lang/python27/pkg-plist16
2 files changed, 1 insertions, 38 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index b64738262dba..1f1a9d07b5e3 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python27
PORTVERSION= 2.7.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -48,7 +48,6 @@ BINLINKS_SUB_TMPL= -e 's,smtpd,smtpd%%VERSION%%,' \
-e 's,2to3,2to3-%%VERSION%%,' \
-e 's,(idle|pydoc|python-shared|python),\1%%VERSION%%,'
BINLINKS_SUB_PYTHON_VER= ${BINLINKS_SUB_TMPL:S/%%VERSION%%/${PYTHON_VER}/g}
-BINLINKS_SUB_PYTHON_MAJOR_VER= ${BINLINKS_SUB_TMPL:S/%%VERSION%%/${PYTHON_MAJOR_VER}/g}
OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES NLS
OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
@@ -80,13 +79,6 @@ SEM_MSG= "@comment "
SUB_FILES= pkg-message
SUB_LIST= SEM=${SEM_MSG}
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
-MLINKS= ${PYTHON_VERSION}.1 python.1
-PLIST_SUB+= IF_DEFAULT=""
-.else
-PLIST_SUB+= IF_DEFAULT="@comment "
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
.if ${PORT_OPTIONS:MPTH}
@@ -274,19 +266,6 @@ post-install:
${INSTALL_MAN} ${PYTHON_WRKSRC}/Misc/python.man \
${MANPREFIX}/man/man1/${PYTHON_VERSION}.1
-.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
- for f in ${BIN_FILES}; do \
- TARGET=`${ECHO_CMD} $$f | ${SED} -E ${BINLINKS_SUB_PYTHON_VER}`; \
- TARGET_MAJOR=`${ECHO_CMD} $$f | ${SED} -E ${BINLINKS_SUB_PYTHON_MAJOR_VER}`; \
- cd ${PREFIX}/bin && ${LN} -sf $$TARGET $$TARGET_MAJOR; \
- cd ${PREFIX}/bin && ${LN} -sf $$TARGET_MAJOR $$f; \
- done
-.endif
-
-.for file in python python-config
- cd ${LOCALBASE}/bin && ${LN} -sf ${file:S/python/${PYTHON_VERSION}/} ${file:S/python/python${PYTHON_MAJOR_VER}/}
-.endfor
-
.if !defined(NOPORTDATA)
@${MKDIR} ${DATADIR}
@cd ${PYTHON_WRKSRC}; ${TAR} -cf - Tools | \
diff --git a/lang/python27/pkg-plist b/lang/python27/pkg-plist
index 02f00218823e..b23e7920146b 100644
--- a/lang/python27/pkg-plist
+++ b/lang/python27/pkg-plist
@@ -1,27 +1,11 @@
libdata/pkgconfig/python-2.7.pc
-%%IF_DEFAULT%%bin/2to3
-%%IF_DEFAULT%%bin/2to3-%%PYMAJOR%%
bin/2to3-%%PYVER%%
-%%IF_DEFAULT%%bin/idle
-%%IF_DEFAULT%%bin/idle%%PYMAJOR%%
bin/idle%%PYVER%%
-%%IF_DEFAULT%%bin/pydoc
-%%IF_DEFAULT%%bin/pydoc%%PYMAJOR%%
bin/pydoc%%PYVER%%
-%%IF_DEFAULT%%bin/python
-%%IF_DEFAULT%%bin/python%%PYMAJOR%%
bin/python%%PYVER%%
-%%IF_DEFAULT%%bin/python-config
-%%IF_DEFAULT%%bin/python%%PYMAJOR%%-config
bin/python%%PYVER%%-config
-%%IF_DEFAULT%%bin/python-shared
-%%IF_DEFAULT%%bin/python-shared%%PYMAJOR%%
bin/python-shared%%PYVER%%
-%%IF_DEFAULT%%bin/python-shared-config
-%%IF_DEFAULT%%bin/python-shared%%PYMAJOR%%-config
bin/python-shared%%PYVER%%-config
-%%IF_DEFAULT%%bin/smtpd.py
-%%IF_DEFAULT%%bin/smtpd%%PYMAJOR%%.py
bin/smtpd%%PYVER%%.py
%%PYTHON_INCLUDEDIR%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%/Python.h