aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python27
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-10-15 23:01:15 +0800
committerantoine <antoine@FreeBSD.org>2017-10-15 23:01:15 +0800
commit5d75c4c2361b79ea55f23927eca7564008bccc2c (patch)
treebfa9fb263de8de1254c4379bb4775434cc596fba /lang/python27
parentf86434cb616824bf0968577196b1b4900de5bbae (diff)
downloadfreebsd-ports-gnome-5d75c4c2361b79ea55f23927eca7564008bccc2c.tar.gz
freebsd-ports-gnome-5d75c4c2361b79ea55f23927eca7564008bccc2c.tar.zst
freebsd-ports-gnome-5d75c4c2361b79ea55f23927eca7564008bccc2c.zip
When cross-compiling with qemu, recompile _sysconfigdata.py after patching it
Reported by: rene@ With hat: portmgr
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 1e465bf76cc8..ae01cf0be349 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,6 +2,7 @@
PORTNAME= python27
PORTVERSION= ${PYTHON_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -143,6 +144,12 @@ post-install:
.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python2.7/_sysconfigdata.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -m compileall -d ${PREFIX}/lib/python2.7 \
+ ${STAGEDIR}${PREFIX}/lib/python2.7/_sysconfigdata.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -O -m compileall -d ${PREFIX}/lib/python2.7 \
+ ${STAGEDIR}${PREFIX}/lib/python2.7/_sysconfigdata.py
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python2.7/config/Makefile
.endif