aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python27
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2017-06-06 20:56:47 +0800
committerkoobs <koobs@FreeBSD.org>2017-06-06 20:56:47 +0800
commitd381570cffb4946f0fb26e358a9fa5914bf9b84a (patch)
treedc349266ef50b39f1af7ccb996591cf377357316 /lang/python27
parent46cdd0bfef50ae56da9f2b01d44c257102c08f48 (diff)
downloadfreebsd-ports-gnome-d381570cffb4946f0fb26e358a9fa5914bf9b84a.tar.gz
freebsd-ports-gnome-d381570cffb4946f0fb26e358a9fa5914bf9b84a.tar.zst
freebsd-ports-gnome-d381570cffb4946f0fb26e358a9fa5914bf9b84a.zip
lang/python{27,33,34,35,36}: Install GDB debugging script
Users with a GDB that supports [1] Python extensions will automatically load the extra debugging extensions when debugging programs that are linked with libpythonX.Y.so.foo. This enables extensions like 'py-bt' and 'py-frame' as described in the Fedora Wiki Article: Easier Python Debugging [2], which can be useful for debugging Python program state from crashes in C extensions, for example. [1] PYTHON option enabled in devel/gdb [2] https://fedoraproject.org/wiki/Features/EasierPythonDebugging PR: 203021 Submitted by: cem Reviewed by: mat, koobs (python) Approved by: koobs (python) Differential Revision: D10398
Diffstat (limited to 'lang/python27')
-rw-r--r--lang/python27/Makefile4
-rw-r--r--lang/python27/pkg-plist1
2 files changed, 4 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index ddeeb5c3ca0d..3f0459c4a432 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python27
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -129,5 +129,7 @@ post-patch:
post-install:
for i in ${STAGEDIR}${PREFIX}/lib/python2.7/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
+ ${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
+ ${STAGEDIR}${PREFIX}/lib/libpython2.7.so.1-gdb.py
.include <bsd.port.mk>
diff --git a/lang/python27/pkg-plist b/lang/python27/pkg-plist
index b54f9e0a79f3..d9a3c4ed01dd 100644
--- a/lang/python27/pkg-plist
+++ b/lang/python27/pkg-plist
@@ -97,6 +97,7 @@ include/python2.7/warnings.h
include/python2.7/weakrefobject.h
lib/libpython2.7.so
lib/libpython2.7.so.1
+lib/libpython2.7.so.1-gdb.py
lib/python2.7/BaseHTTPServer.py
lib/python2.7/BaseHTTPServer.pyc
lib/python2.7/BaseHTTPServer.pyo