aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python2
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-08-18 03:10:59 +0800
committermva <mva@FreeBSD.org>2013-08-18 03:10:59 +0800
commit120b0d35293d8e00d39d7ad2ad7d574983111671 (patch)
tree5fb4dff170d638784a5c9228ee0855dbe6de4641 /lang/python2
parente67297db9d1ad0fca3185a3d0c121af1e8ec2e24 (diff)
downloadfreebsd-ports-gnome-120b0d35293d8e00d39d7ad2ad7d574983111671.tar.gz
freebsd-ports-gnome-120b0d35293d8e00d39d7ad2ad7d574983111671.tar.zst
freebsd-ports-gnome-120b0d35293d8e00d39d7ad2ad7d574983111671.zip
- Move the symlink magic for the default python version into lang/python
and lang/python2 and lang/python3. This change brings us closer to the goal of making Python ports usable with different Python versions at the same time. - Add a new lang/python2 port to handle the symlinks for bin/python2, bin/idle2, bin/pydoc2 and so on. - Add a new lang/python3 port to handle the symlinks for bin/python3, bin/idle3, bin/pydoc3 and so on. - Bump the PORTREVISION on all lang/python* ports.
Diffstat (limited to 'lang/python2')
-rw-r--r--lang/python2/Makefile52
-rw-r--r--lang/python2/pkg-descr4
2 files changed, 56 insertions, 0 deletions
diff --git a/lang/python2/Makefile b/lang/python2/Makefile
new file mode 100644
index 000000000000..99b47276cc13
--- /dev/null
+++ b/lang/python2/Makefile
@@ -0,0 +1,52 @@
+# $FreeBSD$
+
+PORTNAME= python2
+PORTVERSION= ${PYTHON_MAJOR_VER}
+CATEGORIES= lang python ipv6
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= The "meta-port" for version 2 of the Python interpreter
+
+USE_PYTHON_RUN= yes
+PYTHON_VERSION= ${PYTHON_DEFAULT_VERSION}
+NO_BUILD= yes
+
+PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
+ bin/idle${PYTHON_MAJOR_VER} \
+ bin/pydoc${PYTHON_MAJOR_VER} \
+ bin/python${PYTHON_MAJOR_VER} \
+ bin/python${PYTHON_MAJOR_VER}-config \
+ bin/python-shared${PYTHON_MAJOR_VER} \
+ bin/python-shared${PYTHON_MAJOR_VER}-config \
+ bin/smtpd${PYTHON_MAJOR_VER}.py
+
+.include <bsd.port.pre.mk>
+
+do-install:
+.for file in idle pydoc python python-shared
+ ${LN} -sf ${PREFIX}/bin/${file}${PYTHON_VER} ${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}
+.endfor
+ ${LN} -sf ${PREFIX}/bin/2to3-${PYTHON_VER} ${PREFIX}/bin/2to3-${PYTHON_MAJOR_VER}
+ ${LN} -sf ${PREFIX}/bin/smtpd${PYTHON_VER}.py ${PREFIX}/bin/smtpd${PYTHON_MAJOR_VER}.py
+ ${LN} -sf ${PREFIX}/bin/python${PYTHON_VER}-config ${PREFIX}/bin/python${PYTHON_MAJOR_VER}-config
+ ${LN} -sf ${PREFIX}/bin/python-shared${PYTHON_VER}-config ${PREFIX}/bin/python-shared${PYTHON_MAJOR_VER}-config
+
+# Major upgrade support
+PORTUPGRADE_CMD= ${LOCALBASE}/sbin/portupgrade
+
+.if defined(USE_PORTMASTER)
+PORTUPGRADE_CMD= ${LOCALBASE}/sbin/portmaster
+.endif
+
+.if defined(WITH_PKGNG)
+PKG_LIST= ${PKG_BIN} query -a '%n-%v'
+PKG_LIST_FILES= ${PKG_INFO} -l
+.else
+PKG_LIST= ${PKG_INFO} -Ea
+PKG_LIST_FILES= ${PKG_INFO} -L
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/python2/pkg-descr b/lang/python2/pkg-descr
new file mode 100644
index 000000000000..f595c479c814
--- /dev/null
+++ b/lang/python2/pkg-descr
@@ -0,0 +1,4 @@
+Python is an interpreted object-oriented programming language, and is
+often compared to Tcl, Perl or Scheme.
+
+WWW: http://www.python.org/