aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2011-09-25 23:05:18 +0800
committerlwhsu <lwhsu@FreeBSD.org>2011-09-25 23:05:18 +0800
commit2cfa567e139ca7fea8a95b3ae3875c03cb89465d (patch)
tree174b3e926e8901d35bbbf36e21e4e137d514b364 /lang/python32
parente5cfe7554656b5ddebd24975ece0d4d4658e8d90 (diff)
downloadfreebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.tar.gz
freebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.tar.zst
freebsd-ports-gnome-2cfa567e139ca7fea8a95b3ae3875c03cb89465d.zip
- Remove the HUGE_STACK_SIZE option, now Python will use default
thread stack size of the system.
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 85939aaf5095..8d2ebe779c75 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python32
PORTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -49,7 +50,6 @@ BINLINKS_SUB= -e 's,(2to3|idle3|pydoc3),\1-${PYTHON_VER},' \
-e 's,(python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Use python's internal malloc" on \
IPV6 "Enable IPv6 support" on \
@@ -71,11 +71,6 @@ CFLAGS+= -D__wchar_t=wchar_t
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
LDFLAGS+= ${PTHREAD_LIBS}
.else # defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS="@comment "