aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python32
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2006-08-10 18:05:13 +0800
committerperky <perky@FreeBSD.org>2006-08-10 18:05:13 +0800
commitad2be0865518c747c5d9121d00a81115aa2d6a27 (patch)
tree9f36916d73fb6276b447bc0ddeb5afec65d514d1 /lang/python32
parentb453b092e46b857405b14438988e4140f279568f (diff)
downloadfreebsd-ports-gnome-ad2be0865518c747c5d9121d00a81115aa2d6a27.tar.gz
freebsd-ports-gnome-ad2be0865518c747c5d9121d00a81115aa2d6a27.tar.zst
freebsd-ports-gnome-ad2be0865518c747c5d9121d00a81115aa2d6a27.zip
Fix plist for FreeBSD 7 or systems with OpenSSL 0.9.8.
Spotted by: pointyhat via kris
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile5
-rw-r--r--lang/python32/files/patch-setup.py15
2 files changed, 17 insertions, 3 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index c5e43121fc0c..5fe7a8741968 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -174,6 +174,11 @@ pre-install:
/LIBDIR.*\.py$$/ && !/\/bad/ { print $$0 "o"; print $$0 "c"; }' \
${PLIST_TEMPLATE} > ${PLIST}
+ @# if openssl 0.9.8 is detected, _sha{256,512} module won't be installed
+ ([ -f ${WRKSRC}/.without_own_sha ] && \
+ ${GREP} -v 'lib-dynload/_sha' ${PLIST} > ${PLIST}.tmp && \
+ ${CAT} ${PLIST}.tmp > ${PLIST}) || ${TRUE}
+
post-install:
@# install config providers
${INSTALL_SCRIPT} ${WRKDIR}/${PYTHON_VERSION}-config ${PREFIX}/bin
diff --git a/lang/python32/files/patch-setup.py b/lang/python32/files/patch-setup.py
index ebf70e88cb39..cf0beedab0c6 100644
--- a/lang/python32/files/patch-setup.py
+++ b/lang/python32/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Tue Jun 6 08:38:06 2006
-+++ setup.py Fri Jun 23 11:02:35 2006
+--- setup.py.orig Fri Jun 30 15:18:39 2006
++++ setup.py Thu Aug 10 18:41:33 2006
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,7 +9,16 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
-@@ -1470,8 +1470,7 @@
+@@ -590,6 +590,8 @@
+ # OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
+ exts.append( Extension('_sha256', ['sha256module.c']) )
+ exts.append( Extension('_sha512', ['sha512module.c']) )
++ else:
++ open('.without_own_sha', 'w')
+
+
+ # Modules that provide persistent dictionary-like semantics. You will
+@@ -1498,8 +1500,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install