aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python33/Makefile
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2017-08-03 01:58:03 +0800
committersbruno <sbruno@FreeBSD.org>2017-08-03 01:58:03 +0800
commit34dc828faaf1d849dcba7e0286379af468bbb1e9 (patch)
tree3b1e90ac749d4222fcaf237b32ff353b8d8e9fab /lang/python33/Makefile
parent286028b9513cae173b6678a1d38cd6148b863926 (diff)
downloadfreebsd-ports-gnome-34dc828faaf1d849dcba7e0286379af468bbb1e9.tar.gz
freebsd-ports-gnome-34dc828faaf1d849dcba7e0286379af468bbb1e9.tar.zst
freebsd-ports-gnome-34dc828faaf1d849dcba7e0286379af468bbb1e9.zip
Add a code block for the qemu-user enabled cross build environment. When using
this environment in poudriere, CC is not set to the default of /usr/bin/cc and a cross-compile toolchain is used. We need to hand edit this so that the run time configuration for python matches what the FreeBSD base system provides. PR: 208282 Submitted by: manu Approved by: portmgr (mat)
Diffstat (limited to 'lang/python33/Makefile')
-rw-r--r--lang/python33/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index a7cbd32a89f9..3680345c1542 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python33
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
@@ -128,6 +128,17 @@ post-install:
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python3.3/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
+# This code block exists for the qemu-user enabled cross build environment.
+# When using this environment in poudriere, CC is not set to the default
+# of /usr/bin/cc and a cross-compile toolchain is used. We need to hand
+# edit this so that the run time configuration for python matches what the
+# FreeBSD base system provides. sbruno 02Aug2017
+.if ${CC} == /nxb-bin/usr/bin/cc
+ @${REINPLACE_CMD} -e 's=/nxb-bin==' \
+ ${STAGEDIR}${PREFIX}/lib/python3.3./_sysconfigdata.py
+ @${REINPLACE_CMD} -e 's=/nxb-bin==' \
+ ${STAGEDIR}${PREFIX}/lib/python3.3/config-3.3m/Makefile
+.endif
${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
${STAGEDIR}${PREFIX}/lib/libpython3.3${ABIFLAGS}.so.1-gdb.py