aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python33
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2012-12-21 23:45:29 +0800
committerdemon <demon@FreeBSD.org>2012-12-21 23:45:29 +0800
commit0c17b9f7ad9253fe83f7fc2c56934fcd1308d30b (patch)
tree1ce0a1d9c78a5f204de6da3d283e7d4286e31882 /lang/python33
parent40e5ffb5a22cccfe5b4c1a1fc80bcd9ba41be4dd (diff)
downloadfreebsd-ports-gnome-0c17b9f7ad9253fe83f7fc2c56934fcd1308d30b.tar.gz
freebsd-ports-gnome-0c17b9f7ad9253fe83f7fc2c56934fcd1308d30b.tar.zst
freebsd-ports-gnome-0c17b9f7ad9253fe83f7fc2c56934fcd1308d30b.zip
Create python2 symlink for the latest version of python2.X executable and
python3 symlink for the latest version of python3.X executable. People who really want to use older python version for both python branches should specify explicit version number in interpreter invocation. Discussed on python@ long ago.
Diffstat (limited to 'lang/python33')
-rw-r--r--lang/python33/Makefile6
-rw-r--r--lang/python33/pkg-plist2
2 files changed, 8 insertions, 0 deletions
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 6f4a436a57d8..5cfcbb2fc190 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python33
PORTVERSION= 3.3.0
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -36,6 +37,7 @@ PYABIVER= # default empty, for after appending
SHARED_WRKSRC= ${PYTHON_WRKSRC}/portbld.shared
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
+ PYMAJOR=${PYTHON_MAJOR_VER} \
PYVER_WITHPAT=${PORTVERSION:S/.rc/rc/} \
PYABIVER=${PYABIVER} \
PYTHON_SUFFIX=${PYTHON_SUFFIX}
@@ -217,6 +219,10 @@ post-install:
done
.endif
+.for file in python python-config
+ cd ${LOCALBASE}/bin && ${LN} -sf ${file:S/python/${PYTHON_VERSION}/} ${file:S/python/python${PYTHON_MAJOR_VER}/}
+.endfor
+
.if !defined(NOPORTDATA)
@${MKDIR} ${DATADIR}
@cd ${PYTHON_WRKSRC}; ${TAR} -cf - Tools | \
diff --git a/lang/python33/pkg-plist b/lang/python33/pkg-plist
index 5dacb2970960..69b4f7adbaad 100644
--- a/lang/python33/pkg-plist
+++ b/lang/python33/pkg-plist
@@ -5,8 +5,10 @@ bin/idle3-%%PYVER%%
%%IF_DEFAULT%%bin/pydoc3
bin/pydoc3-%%PYVER%%
%%IF_DEFAULT%%bin/python
+bin/python%%PYMAJOR%%
bin/python%%PYVER%%
%%IF_DEFAULT%%bin/python-config
+bin/python%%PYMAJOR%%-config
bin/python%%PYVER%%-config
%%IF_DEFAULT%%bin/python-shared
bin/python-shared%%PYVER%%