aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python33
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
committermat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
commit60e51bda11dcc0742419f2a459990d0d81cb07d8 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /lang/python33
parent3432585b4743642027fc2b3af5eac2780fc2c4cd (diff)
downloadfreebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.gz
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.zst
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Diffstat (limited to 'lang/python33')
-rw-r--r--lang/python33/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 09e03844e866..0ad15145f8ca 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -16,7 +16,8 @@ LICENSE= PSFL
DEPRECATED= No longer receives bug fixes, only security updates. Please update to Python 3.5
EXPIRATION_DATE= 2017-09-01
-USES= cpe ncurses pkgconfig readline ssl tar:xz
+USES= cpe ncurses pathfix pkgconfig readline ssl tar:xz
+PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -28,7 +29,6 @@ CONFIGURE_ENV+= OPT="" # Null out OPT to respect user CFLAGS and remove o
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
-MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support for files other than Makefile.in
MAKE_JOBS_UNSAFE= yes # Parser/pgen build bug. See Issue: 200622, 201974
TEST_TARGET= buildbottest