aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python36
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2019-04-15 00:27:25 +0800
committerantoine <antoine@FreeBSD.org>2019-04-15 00:27:25 +0800
commit772ad9c56ef9bcbe5e28e9fa566a1d113e374388 (patch)
treec5e01ea22c3b53cc34975877acecba7dab5f0f71 /lang/python36
parentf618eefe69cbe438b88096560368718e0cc6a89e (diff)
downloadfreebsd-ports-gnome-772ad9c56ef9bcbe5e28e9fa566a1d113e374388.tar.gz
freebsd-ports-gnome-772ad9c56ef9bcbe5e28e9fa566a1d113e374388.tar.zst
freebsd-ports-gnome-772ad9c56ef9bcbe5e28e9fa566a1d113e374388.zip
Recompile _sysconfigdata.py after reinplacing it
Reported by: tcberner With hat: portmgr
Diffstat (limited to 'lang/python36')
-rw-r--r--lang/python36/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 3b69dde4872b..32909682651c 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -130,6 +130,12 @@ post-install:
.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -O -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}m/Makefile
.endif