aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python37
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2018-12-26 10:24:32 +0800
committerwen <wen@FreeBSD.org>2018-12-26 10:24:32 +0800
commit61d7c4bd5515e799eafd35d408201e82a3df90b1 (patch)
tree2a32e57f8e04bf1adb42056b42887ee133381588 /lang/python37
parent724cba74cea8cbcfb99a55bb4d3a3a46bf3b2962 (diff)
downloadfreebsd-ports-gnome-61d7c4bd5515e799eafd35d408201e82a3df90b1.tar.gz
freebsd-ports-gnome-61d7c4bd5515e799eafd35d408201e82a3df90b1.tar.zst
freebsd-ports-gnome-61d7c4bd5515e799eafd35d408201e82a3df90b1.zip
- Update to 3.7.2
Diffstat (limited to 'lang/python37')
-rw-r--r--lang/python37/Makefile.version2
-rw-r--r--lang/python37/distinfo6
-rw-r--r--lang/python37/files/patch-Makefile.pre.in18
-rw-r--r--lang/python37/pkg-plist19
4 files changed, 27 insertions, 18 deletions
diff --git a/lang/python37/Makefile.version b/lang/python37/Makefile.version
index 69cdd0c7b2fe..9c7a3fccd9d4 100644
--- a/lang/python37/Makefile.version
+++ b/lang/python37/Makefile.version
@@ -1,4 +1,4 @@
# Mk/Uses/python.mk includes this file, don't remove it!
# $FreeBSD$
-PYTHON_PORTVERSION= 3.7.1
+PYTHON_PORTVERSION= 3.7.2
diff --git a/lang/python37/distinfo b/lang/python37/distinfo
index 2554015c741f..49094cc66397 100644
--- a/lang/python37/distinfo
+++ b/lang/python37/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540104377
-SHA256 (python/Python-3.7.1.tar.xz) = fa7e2b8e8c9402f192ad56dc4f814089d1c4466c97d780f5e5acc02c04243d6d
-SIZE (python/Python-3.7.1.tar.xz) = 16960060
+TIMESTAMP = 1545742410
+SHA256 (python/Python-3.7.2.tar.xz) = d83fe8ce51b1bb48bbcf0550fd265b9a75cdfdfa93f916f9e700aef8444bf1bb
+SIZE (python/Python-3.7.2.tar.xz) = 17042320
diff --git a/lang/python37/files/patch-Makefile.pre.in b/lang/python37/files/patch-Makefile.pre.in
index 117a6bb12721..6db68756bbd1 100644
--- a/lang/python37/files/patch-Makefile.pre.in
+++ b/lang/python37/files/patch-Makefile.pre.in
@@ -5,10 +5,9 @@
# Description: Create symlinks for non-ABI-suffixed python*-config and ABI-suffixed python-*.pc
# Submitted by: antoine@ (r358029)
# TODO: Upstream
-
---- Makefile.pre.in.orig 2016-12-26 00:30:30.873942000 +0800
-+++ Makefile.pre.in 2016-12-26 02:51:45.233175000 +0800
-@@ -80,23 +80,20 @@
+--- Makefile.pre.in.orig 2018-12-25 13:00:52 UTC
++++ Makefile.pre.in
+@@ -80,7 +80,6 @@ MAKESETUP= $(srcdir)/Modules/makesetup
OPT= @OPT@
BASECFLAGS= @BASECFLAGS@
BASECPPFLAGS= @BASECPPFLAGS@
@@ -16,7 +15,10 @@
# CFLAGS_NODIST is used for building the interpreter and stdlib C extensions.
# Use it when a compiler flag should _not_ be part of the distutils CFLAGS
# once Python is installed (Issue #21121).
- CONFIGURE_CFLAGS_NODIST=@CFLAGS_NODIST@
+@@ -89,18 +88,16 @@ CONFIGURE_CFLAGS_NODIST=@CFLAGS_NODIST@
+ # Use it when a linker flag should _not_ be part of the distutils LDFLAGS
+ # once Python is installed (bpo-35257)
+ CONFIGURE_LDFLAGS_NODIST=@LDFLAGS_NODIST@
-CONFIGURE_CPPFLAGS= @CPPFLAGS@
-CONFIGURE_LDFLAGS= @LDFLAGS@
# Avoid assigning CFLAGS, LDFLAGS, etc. so users can use them on the
@@ -32,10 +34,10 @@
-PY_LDFLAGS= $(CONFIGURE_LDFLAGS) $(LDFLAGS)
+PY_CPPFLAGS= $(BASECPPFLAGS) -I. -I$(srcdir)/Include $(CPPFLAGS)
+PY_LDFLAGS= $(LDFLAGS)
+ PY_LDFLAGS_NODIST=$(CONFIGURE_LDFLAGS_NODIST) $(LDFLAGS_NODIST)
NO_AS_NEEDED= @NO_AS_NEEDED@
LDLAST= @LDLAST@
- SGI_ABI= @SGI_ABI@
-@@ -1145,12 +1142,6 @@
+@@ -1213,12 +1210,6 @@ bininstall: altbininstall
else true; \
fi
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python3$(EXE))
@@ -48,7 +50,7 @@
-rm -f $(DESTDIR)$(BINDIR)/python3-config
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python3-config)
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
-@@ -1412,6 +1403,12 @@
+@@ -1505,6 +1496,12 @@ libainstall: @DEF_MAKE_RULE@ python-config
$(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
$(INSTALL_SCRIPT) python-config.py $(DESTDIR)$(LIBPL)/python-config.py
$(INSTALL_SCRIPT) python-config $(DESTDIR)$(BINDIR)/python$(LDVERSION)-config
diff --git a/lang/python37/pkg-plist b/lang/python37/pkg-plist
index f8744da5baa7..ef52de03fc2e 100644
--- a/lang/python37/pkg-plist
+++ b/lang/python37/pkg-plist
@@ -41,6 +41,17 @@ include/python%%XYDOT%%%%ABI%%/genobject.h
include/python%%XYDOT%%%%ABI%%/graminit.h
include/python%%XYDOT%%%%ABI%%/grammar.h
include/python%%XYDOT%%%%ABI%%/import.h
+include/python%%XYDOT%%%%ABI%%/internal/ceval.h
+include/python%%XYDOT%%%%ABI%%/internal/condvar.h
+include/python%%XYDOT%%%%ABI%%/internal/context.h
+include/python%%XYDOT%%%%ABI%%/internal/gil.h
+include/python%%XYDOT%%%%ABI%%/internal/hamt.h
+include/python%%XYDOT%%%%ABI%%/internal/hash.h
+include/python%%XYDOT%%%%ABI%%/internal/import.h
+include/python%%XYDOT%%%%ABI%%/internal/mem.h
+include/python%%XYDOT%%%%ABI%%/internal/pygetopt.h
+include/python%%XYDOT%%%%ABI%%/internal/pystate.h
+include/python%%XYDOT%%%%ABI%%/internal/warnings.h
include/python%%XYDOT%%%%ABI%%/intrcheck.h
include/python%%XYDOT%%%%ABI%%/iterobject.h
include/python%%XYDOT%%%%ABI%%/listobject.h
@@ -2124,8 +2135,8 @@ lib/python%%XYDOT%%/ensurepip/__pycache__/__main__.cpython-%%XY%%.pyc
lib/python%%XYDOT%%/ensurepip/__pycache__/_uninstall.cpython-%%XY%%.opt-1.pyc
lib/python%%XYDOT%%/ensurepip/__pycache__/_uninstall.cpython-%%XY%%.opt-2.pyc
lib/python%%XYDOT%%/ensurepip/__pycache__/_uninstall.cpython-%%XY%%.pyc
-lib/python%%XYDOT%%/ensurepip/_bundled/pip-10.0.1-py2.py3-none-any.whl
-lib/python%%XYDOT%%/ensurepip/_bundled/setuptools-39.0.1-py2.py3-none-any.whl
+lib/python%%XYDOT%%/ensurepip/_bundled/pip-18.1-py2.py3-none-any.whl
+lib/python%%XYDOT%%/ensurepip/_bundled/setuptools-40.6.2-py2.py3-none-any.whl
lib/python%%XYDOT%%/ensurepip/_uninstall.py
lib/python%%XYDOT%%/enum.py
lib/python%%XYDOT%%/filecmp.py
@@ -5383,10 +5394,6 @@ lib/python%%XYDOT%%/test/test_asyncio/echo.py
lib/python%%XYDOT%%/test/test_asyncio/echo2.py
lib/python%%XYDOT%%/test/test_asyncio/echo3.py
lib/python%%XYDOT%%/test/test_asyncio/functional.py
-lib/python%%XYDOT%%/test/test_asyncio/keycert3.pem
-lib/python%%XYDOT%%/test/test_asyncio/pycacert.pem
-lib/python%%XYDOT%%/test/test_asyncio/ssl_cert.pem
-lib/python%%XYDOT%%/test/test_asyncio/ssl_key.pem
lib/python%%XYDOT%%/test/test_asyncio/test_base_events.py
lib/python%%XYDOT%%/test/test_asyncio/test_buffered_proto.py
lib/python%%XYDOT%%/test/test_asyncio/test_context.py