aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python3
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-08-18 23:25:24 +0800
committermva <mva@FreeBSD.org>2013-08-18 23:25:24 +0800
commit7ba7a924d5986f919c0d09fdd256b9751333f788 (patch)
tree08a2f18bdbefddb1f468c74b133fb51bc176f7d3 /lang/python3
parente38d0a6d9ce99fcab550ab1da642fed9c83f336d (diff)
downloadfreebsd-ports-gnome-7ba7a924d5986f919c0d09fdd256b9751333f788.tar.gz
freebsd-ports-gnome-7ba7a924d5986f919c0d09fdd256b9751333f788.tar.zst
freebsd-ports-gnome-7ba7a924d5986f919c0d09fdd256b9751333f788.zip
- Avoid circular dependencies due to the previous bsd.python.mk change
Diffstat (limited to 'lang/python3')
-rw-r--r--lang/python3/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/python3/Makefile b/lang/python3/Makefile
index 3ac4fbebd9e7..b3ea216b0db9 100644
--- a/lang/python3/Makefile
+++ b/lang/python3/Makefile
@@ -13,6 +13,7 @@ COMMENT= The "meta-port" for version 3 of the Python interpreter
USE_PYTHON_RUN= yes
PYTHON_VERSION= ${PYTHON3_DEFAULT_VERSION}
NO_BUILD= yes
+PYTHON_NO_DEPENDS= yes
PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
bin/idle${PYTHON_MAJOR_VER} \
@@ -24,6 +25,8 @@ PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
.include <bsd.port.pre.mk>
+RUN_DEPENDS+= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
+
do-install:
.for file in python python-shared
${LN} -sf ${PREFIX}/bin/${file}${PYTHON_VER} ${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}