aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python3
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-01-25 17:15:12 +0800
committermva <mva@FreeBSD.org>2014-01-25 17:15:12 +0800
commitcf1583e5a6912c37ec1fbb5f614c57cca78e38c3 (patch)
tree6a5600a7a78cee12084b4afcbf9ef39c8603bc99 /lang/python3
parentbb5b3715b3f7bf1ce1a8cf386b170c3f4ceaa4c9 (diff)
downloadfreebsd-ports-gnome-cf1583e5a6912c37ec1fbb5f614c57cca78e38c3.tar.gz
freebsd-ports-gnome-cf1583e5a6912c37ec1fbb5f614c57cca78e38c3.tar.zst
freebsd-ports-gnome-cf1583e5a6912c37ec1fbb5f614c57cca78e38c3.zip
- Do not use absolute source paths for the symlinks to the stagedir
Noticed by: danfe
Diffstat (limited to 'lang/python3')
-rw-r--r--lang/python3/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/python3/Makefile b/lang/python3/Makefile
index c1eeff26217c..9471bba972c4 100644
--- a/lang/python3/Makefile
+++ b/lang/python3/Makefile
@@ -31,20 +31,20 @@ RUN_DEPENDS+= ${PYTHON_CMD}:${PYTHON_PORTSDIR}
do-install:
.for file in python python-shared
- ${LN} -sf ${PREFIX}/bin/${file}${PYTHON_VER} \
+ ${LN} -sf ${file}${PYTHON_VER} \
${STAGEDIR}${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}
.endfor
- ${LN} -sf ${PREFIX}/bin/2to3-${PYTHON_VER} \
+ ${LN} -sf 2to3-${PYTHON_VER} \
${STAGEDIR}${PREFIX}/bin/2to3-${PYTHON_MAJOR_VER}
.for file in idle pydoc
- ${LN} -sf ${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}-${PYTHON_VER} \
+ ${LN} -sf ${file}${PYTHON_MAJOR_VER}-${PYTHON_VER} \
${STAGEDIR}${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}
.endfor
- ${LN} -sf ${PREFIX}/bin/python${PYTHON_VER}-config \
+ ${LN} -sf python${PYTHON_VER}-config \
${STAGEDIR}${PREFIX}/bin/python${PYTHON_MAJOR_VER}-config
- ${LN} -sf ${PREFIX}/bin/python-shared${PYTHON_VER}-config \
+ ${LN} -sf python-shared${PYTHON_VER}-config \
${STAGEDIR}${PREFIX}/bin/python-shared${PYTHON_MAJOR_VER}-config
- ${LN} -sf ${PREFIX}/libdata/pkgconfig/python-${PYTHON_VER}.pc \
+ ${LN} -sf python-${PYTHON_VER}.pc \
${STAGEDIR}${PREFIX}/libdata/pkgconfig/python${PYTHON_MAJOR_VER}.pc
# Major upgrade support