aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-05-07 13:39:33 +0800
committerperky <perky@FreeBSD.org>2004-05-07 13:39:33 +0800
commit8e47c4516760a7976e31eb1d32530d07ff12c68d (patch)
treee676f5af8a3a7ec3e03128e4cfcbd5823ffc81fd /lang/python
parent7f350e4644aab17051565d8c2cb14de57e9d66ab (diff)
downloadfreebsd-ports-gnome-8e47c4516760a7976e31eb1d32530d07ff12c68d.tar.gz
freebsd-ports-gnome-8e47c4516760a7976e31eb1d32530d07ff12c68d.tar.zst
freebsd-ports-gnome-8e47c4516760a7976e31eb1d32530d07ff12c68d.zip
Use OPTIONS.
Submitted by: Stephane E. Potvin <sepotvin@videotron.ca>
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 5bee1a4457bc..149b35f9877d 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -38,27 +38,30 @@ PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//}
DEMODIR= ${PREFIX}/share/examples/${PYTHON_VERSION}
TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
-#
-# If you don't want to use Python's thread module, you need to set
-# WITHOUT_THREADS.
-#
-.if !defined(WITHOUT_THREADS)
+OPTIONS= THREADS "Enable thread support" on \
+ HUGE_STACK_SIZE "Use a larger thread stack" off \
+ UCS2 "Use UCS2 instead of UCS4 for unicode support" off \
+ PYMALLOC "Uses python's internal malloc" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if !defined(WANT_HUGE_STACK_SIZE)
+.if defined(WITHOUT_HUGE_STACK_SIZE)
CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
.else
CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # !defined(WANT_HUGE_STACK_SIZE)
+.endif # defined(WITHOUT_HUGE_STACK_SIZE)
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
.else
CONFIGURE_ARGS+= --without-threads
.if defined(LDFLAGS)
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.endif # defined(LDFLAGS)
-.endif # !defined(WITHOUT_THREADS)
+.endif # defined(WITH_THREADS)
-.if !defined(WITH_UCS2)
+.if defined(WITHOUT_UCS2)
CONFIGURE_ARGS+= --enable-unicode=ucs4
.endif
@@ -66,8 +69,6 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --without-pymalloc
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == i386
PLIST_SUB+= X86_ONLY=""
.else