aboutsummaryrefslogtreecommitdiffstats
path: root/lang/q
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-11-22 16:35:23 +0800
committermiwi <miwi@FreeBSD.org>2007-11-22 16:35:23 +0800
commit2ef410e3e18d5aad10a1a45c443a9075a88bc683 (patch)
tree981134de85cf83163a63eb7849db80f2affe5441 /lang/q
parent83f7fe7569aaf7934b803e4d522ed119ac075434 (diff)
downloadfreebsd-ports-gnome-2ef410e3e18d5aad10a1a45c443a9075a88bc683.tar.gz
freebsd-ports-gnome-2ef410e3e18d5aad10a1a45c443a9075a88bc683.tar.zst
freebsd-ports-gnome-2ef410e3e18d5aad10a1a45c443a9075a88bc683.zip
- Fix build with gcc 4.2
PR: 118029 Submitted by: Pietro Cerutti <gahr@gahr.ch> Approved by: portmgr (erwin)
Diffstat (limited to 'lang/q')
-rw-r--r--lang/q/Makefile4
-rw-r--r--lang/q/files/patch-modules-octave_octave.c19
-rw-r--r--lang/q/files/patch-src_qmparse.y10
3 files changed, 29 insertions, 4 deletions
diff --git a/lang/q/Makefile b/lang/q/Makefile
index 5505397fa8a2..c5af638ea287 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -80,10 +80,6 @@ INFO= qdoc
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if ${ARCH} == "amd64"
BROKEN= Does not build on amd64 (shared libraries must be compiled with -fPIC)
.endif
diff --git a/lang/q/files/patch-modules-octave_octave.c b/lang/q/files/patch-modules-octave_octave.c
new file mode 100644
index 000000000000..891db66f7685
--- /dev/null
+++ b/lang/q/files/patch-modules-octave_octave.c
@@ -0,0 +1,19 @@
+--- modules/octave/octave.c.orig 2007-11-14 03:04:18.000000000 +0100
++++ modules/octave/octave.c 2007-11-14 03:06:27.000000000 +0100
+@@ -126,6 +126,8 @@
+ static const char *octaverc = ".octaverc";
+ static const char *octaverc_bak = ".octaverc.$$$";
+
++static int send_octave(char *);
++
+ /* handle SIGINT and SIGTERM */
+
+ #if RETSIGTYPE == void
+@@ -272,7 +274,6 @@
+ FILE *fp, *fp2;
+ char buf[bufsz];
+ int bak = 0;
+- static int send_octave(char *cmd);
+ static int init = 0;
+ if (!octp) {
+ /* get the command from the OCTAVE variable if defined */
diff --git a/lang/q/files/patch-src_qmparse.y b/lang/q/files/patch-src_qmparse.y
new file mode 100644
index 000000000000..a07f756d502e
--- /dev/null
+++ b/lang/q/files/patch-src_qmparse.y
@@ -0,0 +1,10 @@
+--- src/qmparse.y.orig 2007-11-14 03:07:31.000000000 +0100
++++ src/qmparse.y 2007-11-14 03:09:06.000000000 +0100
+@@ -239,7 +239,6 @@
+
+ | _PROMPT_ arg_list
+ {
+- static savepos();
+ char **argv = $2.v;
+ int argc = $2.c, i;
+ if (argc == 0) {