aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rhino/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-08-08 22:05:10 +0800
committerpav <pav@FreeBSD.org>2011-08-08 22:05:10 +0800
commit6424e6c89c764897156a4c4a35265e593881091b (patch)
treed69b33f412292310b1a69da24ef8d66ab75abf20 /lang/rhino/Makefile
parent68bfea891f0f8130083cae458ac40064b482f505 (diff)
downloadfreebsd-ports-gnome-6424e6c89c764897156a4c4a35265e593881091b.tar.gz
freebsd-ports-gnome-6424e6c89c764897156a4c4a35265e593881091b.tar.zst
freebsd-ports-gnome-6424e6c89c764897156a4c4a35265e593881091b.zip
- Update to 1_7R3 and update xmlbeans to 2.5.0
PR: ports/158438 Submitted by: Pedro Giffuni <giffunip@tutopia.com> Approved by: maintainer timeout (nivit; 1 month)
Diffstat (limited to 'lang/rhino/Makefile')
-rw-r--r--lang/rhino/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/rhino/Makefile b/lang/rhino/Makefile
index 35e61d122aa4..e6d82cd68264 100644
--- a/lang/rhino/Makefile
+++ b/lang/rhino/Makefile
@@ -6,9 +6,7 @@
#
PORTNAME= rhino
-DISTVERSION= 1_7R2
-PORTREVISION= 0
-#PORTEPOCH= 0
+DISTVERSION= 1_7R3
CATEGORIES= lang java
MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla.org/js/:rhino \
http://java.sun.com/products/jfc/tsc/articles/treetable2/downloads/:swingex \
@@ -16,13 +14,15 @@ MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla.org/js/:rhino \
MASTER_SITE_SUBDIR= xmlbeans/binaries/:xmlbeans
DISTFILES= ${PORTNAME}${DISTVERSION}.zip:rhino \
src.zip:swingex \
- xmlbeans-2.2.0.zip:xmlbeans
+ xmlbeans-2.5.0.zip:xmlbeans
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}${DISTVERSION}.zip
MAINTAINER= nivit@FreeBSD.org
COMMENT= An implementation of JavaScript written in Java
+LICENSE= MPL
+
OPTIONS= LINEDIT "Enable line editing in the Rhino shell" on
ALL_TARGET= jar
@@ -31,7 +31,7 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
JAVA_VERSION= 1.5+
-MAKE_ARGS= -Dxmlbeans.url=file://${DISTDIR}/${DIST_SUBDIR}/xmlbeans-2.2.0.zip \
+MAKE_ARGS= -Dxmlbeans.url=file://${DISTDIR}/${DIST_SUBDIR}/xmlbeans-2.5.0.zip \
-Dswing-ex-url=file://${DISTDIR}/${DIST_SUBDIR}/src.zip
RHINOJAR= ${DATADIR}/${PORTNAME}.jar