aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-06 04:36:33 +0800
committerpav <pav@FreeBSD.org>2009-01-06 04:36:33 +0800
commit460836ff23b6dcedf0492f75495022dc42f6eb99 (patch)
tree5c97de462ec70569d72e34d640782d1b9348d6de /lang/ruby18
parentfbbcbe4a59e1074c58bbdabf056cd9c13db27392 (diff)
downloadfreebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.tar.gz
freebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.tar.zst
freebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.zip
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile6
-rw-r--r--lang/ruby18/files/extrapatch-eval.c13
2 files changed, 1 insertions, 18 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 9a3c2055ec6b..546233d2a967 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -88,10 +88,6 @@ CONFIGURE_ARGS+= --enable-install-doc
CONFIGURE_ARGS+= --disable-install-doc
.endif
-.if ${OSVERSION} < 502102
-EXTRA_PATCHES= ${PATCHDIR}/extrapatch-eval.c
-.endif
-
# This patch can be used for GC performance analysis and tweaking
# svn://rubyforge.org/var/svn/railsbench/trunk/railsbench/ruby185gc.patch
.if defined(WITH_GCPATCH)
@@ -142,7 +138,7 @@ post-extract:
${MV} ${WRKSRC}/ext/dl/h2rb ${WRKSRC}/bin/
post-patch:
-.if ${OSVERSION} < 502102 || ${ARCH} == "sparc64" || ${ARCH} == "alpha"
+.if ${ARCH} == "sparc64" || ${ARCH} == "alpha"
${REINPLACE_CMD} -e 's|-lc"|"|g' ${WRKSRC}/configure
.endif
${REINPLACE_CMD} -e 's|-l$$pthread_lib|${PTHREAD_LIBS}|g' \
diff --git a/lang/ruby18/files/extrapatch-eval.c b/lang/ruby18/files/extrapatch-eval.c
deleted file mode 100644
index 4d9785c75d7f..000000000000
--- a/lang/ruby18/files/extrapatch-eval.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- eval.c.orig Wed Feb 23 15:54:03 2005
-+++ eval.c Wed Feb 23 15:54:18 2005
-@@ -12,6 +12,10 @@
-
- **********************************************************************/
-
-+#ifdef _THREAD_SAFE
-+#undef _THREAD_SAFE
-+#endif
-+
- #include "ruby.h"
- #include "node.h"
- #include "env.h"