aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby21
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
committertijl <tijl@FreeBSD.org>2014-06-11 22:49:59 +0800
commit67f12d415fec83113a7ddfbc9655db98b4e70a28 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /lang/ruby21
parent2088f53b95d04c86b1aece3d66aaca36ec5aaec2 (diff)
downloadfreebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.gz
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.tar.zst
freebsd-ports-gnome-67f12d415fec83113a7ddfbc9655db98b4e70a28.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'lang/ruby21')
-rw-r--r--lang/ruby21/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index 6ca089a7db7a..cb2fd8827ff4 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -70,8 +70,9 @@ _SUF2= ,${PORTEPOCH}
_SUF1= _${PORTREVISION}
.endif
-CFLAGS+= ${PTHREAD_CFLAGS} # Keep this, else ruby will fail to load
-LDFLAGS+= ${PTHREAD_LIBS} # libraries dependent op libpthread.
+CPPFLAGS+= -I${LOCALBASE}/include
+# Keep this, else ruby will fail to load libraries dependent op libpthread.
+LIBS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
#
# Disable doc generation if requested or docs disabled at all
@@ -86,9 +87,7 @@ CONFIGURE_ARGS+= --disable-install-doc
CONFIGURE_ARGS+= --disable-dtrace
.endif
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib ${LDFLAGS}" \
- debugflags=
+CONFIGURE_ENV= debugflags=
.if ${PORT_OPTIONS:MLIBEDIT}
BUILD_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit