aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby_r-devel/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-06-04 23:02:52 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2001-06-04 23:02:52 +0800
commit70782b1469282cb2ed4f90aac28ea8adcb3f99d9 (patch)
tree15844e032938bdbb066239ca1febd25e7111badd /lang/ruby_r-devel/Makefile
parent9b3bcd846b06465a7b9f916c7e56af110938d082 (diff)
downloadfreebsd-ports-gnome-70782b1469282cb2ed4f90aac28ea8adcb3f99d9.tar.gz
freebsd-ports-gnome-70782b1469282cb2ed4f90aac28ea8adcb3f99d9.tar.zst
freebsd-ports-gnome-70782b1469282cb2ed4f90aac28ea8adcb3f99d9.zip
Add lang/ruby_r and lang/ruby_r-devel, ruby binary linked with libc_r.
As there are unidentified problems with libc_r + ruby, please use this with care. I'd appreciate if any of you could join me in debugging.
Diffstat (limited to 'lang/ruby_r-devel/Makefile')
-rw-r--r--lang/ruby_r-devel/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/lang/ruby_r-devel/Makefile b/lang/ruby_r-devel/Makefile
new file mode 100644
index 000000000000..f509dfda60d7
--- /dev/null
+++ b/lang/ruby_r-devel/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: ruby_r-devel
+# Date created: 3 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../ruby-devel
+
+RUBY_VER= 1.7
+
+BUILD_DEPENDS= ${RUBY_WITHOUT_SUFFIX}${RUBY_VER:S/.//}:${MASTERDIR}
+RUN_DEPENDS= ${RUBY_WITHOUT_SUFFIX}${RUBY_VER:S/.//}:${MASTERDIR}
+
+NOPORTDOCS= yes
+NORUBYLIB= yes
+
+RUBY_WITH_PTHREAD= yes
+
+.include "${MASTERDIR}/Makefile"