aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rust
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2018-01-25 21:59:23 +0800
committerdumbbell <dumbbell@FreeBSD.org>2018-01-25 21:59:23 +0800
commit6dea92a20fd2e3c3700e06dfff15ce9a21d3b679 (patch)
treead87c0fa5d0eae8423e7c6112ea0e7d7de6c4501 /lang/rust
parent9eb1f4bdd444315eed2fa715f34b8001b0d03bd9 (diff)
downloadfreebsd-ports-gnome-6dea92a20fd2e3c3700e06dfff15ce9a21d3b679.tar.gz
freebsd-ports-gnome-6dea92a20fd2e3c3700e06dfff15ce9a21d3b679.tar.zst
freebsd-ports-gnome-6dea92a20fd2e3c3700e06dfff15ce9a21d3b679.zip
lang/rust: Add manifest-rustfmt-preview to PLIST
This wasn't reported by a simple `poudriere bulk`, but a `poudriere testport` revealed the problem: ====> Running Q/A tests (stage-qa) Error: 'lib/rustlib/manifest-rustfmt-preview' is referring to /wrkdirs/usr/ports/lang/rust/work/stage Warning: 'bin/rustfmt' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD} ... ===> Checking for items in STAGEDIR missing from pkg-plist Error: Orphaned: bin/rustfmt Error: Orphaned: lib/rustlib/manifest-rustfmt-preview PR: 225445 Reported by: jbeich@
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index d4d26bb5d09e..cba513abc8f1 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -78,6 +78,7 @@ LLNEXTGEN_BUILD_DEPENDS= LLnextgen:devel/llnextgen
RUST_MANIFESTS= lib/rustlib/manifest-cargo \
lib/rustlib/manifest-rls-preview \
lib/rustlib/manifest-rustc \
+ lib/rustlib/manifest-rustfmt-preview \
lib/rustlib/manifest-rust-analysis-${RUST_TARGET} \
lib/rustlib/manifest-rust-std-${RUST_TARGET}
RUST_DOCS_MANIFEST= lib/rustlib/manifest-rust-docs
@@ -312,6 +313,7 @@ post-install:
${STAGEDIR}${PREFIX}/bin/rls \
${STAGEDIR}${PREFIX}/bin/rustc \
${STAGEDIR}${PREFIX}/bin/rustdoc \
+ ${STAGEDIR}${PREFIX}/bin/rustfmt \
${STAGEDIR}${PREFIX}/lib/*.so \
${STAGEDIR}${PREFIX}/lib/rustlib/*/lib/*.so