aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rust
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2017-07-29 06:30:39 +0800
committerdumbbell <dumbbell@FreeBSD.org>2017-07-29 06:30:39 +0800
commit987aa39fa0f26904fecfb84bb08ec13e4e23090e (patch)
tree0b75afee1613c497290feef953796bbac7605bae /lang/rust
parent26d25c0f7ef1ace2e9b924fa59069ddaebf26d87 (diff)
downloadfreebsd-ports-gnome-987aa39fa0f26904fecfb84bb08ec13e4e23090e.tar.gz
freebsd-ports-gnome-987aa39fa0f26904fecfb84bb08ec13e4e23090e.tar.zst
freebsd-ports-gnome-987aa39fa0f26904fecfb84bb08ec13e4e23090e.zip
lang/rust: Fix build with PORT_LLVM
The path to `llvm-config40` was set to the empty string in the generated `config.toml`, because I was still using the ${LLVM_PREFIX} variable instead of the appropriate ${LLVM_CONFIG}. Bad completion and lack of testing, sorry for that... Reported by: Rainer Hurling <rhurlin@gwdg.de>, Walter Schwarzenfeld <w.schwarzenfeld@utanet.at>, dim@
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 8a41b9211627..602dec9eddc4 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -72,6 +72,7 @@ PLIST_SUB+= RUST_TARGET=${RUST_TARGET}
USES= compiler gmake libedit python:2.7,build
OPTIONS_DEFINE= DOCS GDB LLNEXTGEN PORT_LLVM
+OPTIONS_DEFAULT= PORT_LLVM
GDB_DESC= Install ports gdb (necessary for debugging rust programs)
LLNEXTGEN_DESC= Build with grammar verification
@@ -197,7 +198,7 @@ post-configure-DOCS-off:
${REINPLACE_CMD} -e 's,%DOCS%,false,' ${WRKSRC}/config.toml
post-configure-PORT_LLVM-on:
- ${REINPLACE_CMD} -e 's,%LLVM_CONFIG%,${LLVM_PREFIX},' ${WRKSRC}/config.toml
+ ${REINPLACE_CMD} -e 's,%LLVM_CONFIG%,${LLVM_CONFIG},' ${WRKSRC}/config.toml
post-configure-PORT_LLVM-off:
${REINPLACE_CMD} -e '/%LLVM_CONFIG%/d' ${WRKSRC}/config.toml