aboutsummaryrefslogtreecommitdiffstats
path: root/lang/rust
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2017-10-29 20:38:09 +0800
committerdumbbell <dumbbell@FreeBSD.org>2017-10-29 20:38:09 +0800
commitce111350a1667891328bd1c2c9fb2a9529f1be93 (patch)
tree9ef48fa7777f5d1fb1fb4b1f7814d088ea91f6e7 /lang/rust
parent9d2c4a462d74e49c1955ccb547b9e11a7e8b8786 (diff)
downloadfreebsd-ports-gnome-ce111350a1667891328bd1c2c9fb2a9529f1be93.tar.gz
freebsd-ports-gnome-ce111350a1667891328bd1c2c9fb2a9529f1be93.tar.zst
freebsd-ports-gnome-ce111350a1667891328bd1c2c9fb2a9529f1be93.zip
lang/rust: Fix paths in `manifest-rls-preview`
Like other manifests, without this, it still references the stage directory. This error is reported when DEVELOPER=YES is set. While here, strip `bin/rls`. Reported by: bar@, cpm@
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index c5d51ee898de..2bf85361a4e3 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rust
PORTVERSION?= 1.21.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
LOCAL/dumbbell/rust:rust_bootstrap \
@@ -82,6 +83,7 @@ LLVM_CONFIG= ${LOCALBASE}/bin/llvm-config${LLVM_VER}
# - pre-install to cleanup the ${STAGEDIR}
# - post-install to populate the ${TMPPLIST}
RUST_MANIFESTS= lib/rustlib/manifest-cargo \
+ lib/rustlib/manifest-rls-preview \
lib/rustlib/manifest-rustc \
lib/rustlib/manifest-rust-analysis-${RUST_TARGET} \
lib/rustlib/manifest-rust-std-${RUST_TARGET}
@@ -321,6 +323,7 @@ post-install:
# but they contain non-object files which make strip(1) unhappy.
@${STRIP_CMD} \
${STAGEDIR}${PREFIX}/bin/cargo \
+ ${STAGEDIR}${PREFIX}/bin/rls \
${STAGEDIR}${PREFIX}/bin/rustc \
${STAGEDIR}${PREFIX}/bin/rustdoc \
${STAGEDIR}${PREFIX}/lib/*.so \