aboutsummaryrefslogtreecommitdiffstats
path: root/lang/sbcl
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-09-22 10:33:08 +0800
committerstas <stas@FreeBSD.org>2011-09-22 10:33:08 +0800
commit37c781a35253482b55de83865baee98a93d09530 (patch)
tree914716eede74f7e102a72a3d73f4bd0bcbda8fb6 /lang/sbcl
parent0925944cc5a74e5e3849553ed76553c11ef3fa14 (diff)
downloadfreebsd-ports-gnome-37c781a35253482b55de83865baee98a93d09530.tar.gz
freebsd-ports-gnome-37c781a35253482b55de83865baee98a93d09530.tar.zst
freebsd-ports-gnome-37c781a35253482b55de83865baee98a93d09530.zip
- Fix build with CLANG.
PR: ports/160327 Reported by: "Hartmann, O." <ohartman@zedat.fu-berlin.de> Submitted by: h h <aakuusta@gmail.com> Obtained from: sbcl bugtracker: https://bugs.launchpad.net/sbcl/+
Diffstat (limited to 'lang/sbcl')
-rw-r--r--lang/sbcl/files/patch-contrib_asdf-module.mk8
-rw-r--r--lang/sbcl/files/patch-src_runtime_gencgc-internal.h13
2 files changed, 21 insertions, 0 deletions
diff --git a/lang/sbcl/files/patch-contrib_asdf-module.mk b/lang/sbcl/files/patch-contrib_asdf-module.mk
new file mode 100644
index 000000000000..1e9c654b0d1f
--- /dev/null
+++ b/lang/sbcl/files/patch-contrib_asdf-module.mk
@@ -0,0 +1,8 @@
+--- contrib/asdf-module.mk.orig 2011-09-21 17:44:49.000000000 -0700
++++ contrib/asdf-module.mk 2011-09-21 17:45:24.000000000 -0700
+@@ -1,4 +1,4 @@
+-CC=cc
++CC?=cc
+
+ # We need to extend flags to the C compiler and the linker
+ # here. sb-posix, sb-grovel, and sb-bsd-sockets depends upon these
diff --git a/lang/sbcl/files/patch-src_runtime_gencgc-internal.h b/lang/sbcl/files/patch-src_runtime_gencgc-internal.h
new file mode 100644
index 000000000000..25429a69d2a6
--- /dev/null
+++ b/lang/sbcl/files/patch-src_runtime_gencgc-internal.h
@@ -0,0 +1,13 @@
+--- src/runtime/gencgc-internal.h.orig 2011-09-21 17:45:32.000000000 -0700
++++ src/runtime/gencgc-internal.h 2011-09-21 17:46:00.000000000 -0700
+@@ -25,8 +25,8 @@
+ #include "genesis/code.h"
+
+ void gc_free_heap(void);
+-inline page_index_t find_page_index(void *);
+-inline void *page_address(page_index_t);
++extern page_index_t find_page_index(void *);
++extern void *page_address(page_index_t);
+ int gencgc_handle_wp_violation(void *);
+
+