aboutsummaryrefslogtreecommitdiffstats
path: root/lang/see/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2008-01-29 17:36:03 +0800
committervanilla <vanilla@FreeBSD.org>2008-01-29 17:36:03 +0800
commit7cf4571540eb9ceeded052c5ad88b69b75efd75b (patch)
treefaa4635e4c3a6e799b109c08d46607cecdd7fecf /lang/see/Makefile
parent4d2c107b1f35cee1a4cff46d21e0b002071cc15d (diff)
downloadfreebsd-ports-gnome-7cf4571540eb9ceeded052c5ad88b69b75efd75b.tar.gz
freebsd-ports-gnome-7cf4571540eb9ceeded052c5ad88b69b75efd75b.tar.zst
freebsd-ports-gnome-7cf4571540eb9ceeded052c5ad88b69b75efd75b.zip
Upgrade to 2.0.1131.
PR: ports/120082 Submitted by: maintainer
Diffstat (limited to 'lang/see/Makefile')
-rw-r--r--lang/see/Makefile33
1 files changed, 20 insertions, 13 deletions
diff --git a/lang/see/Makefile b/lang/see/Makefile
index 06079d909789..3a21f2cc9000 100644
--- a/lang/see/Makefile
+++ b/lang/see/Makefile
@@ -1,40 +1,47 @@
# New ports collection makefile for: see
-# Date created: 22 September 2004
-# Whom: numisemis@yahoo.com
+# Date created: 29 Oct 2005
+# Whom: Simun Mikecin <numisemis@yahoo.com>
#
# $FreeBSD$
#
PORTNAME= see
-PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTVERSION= 2.0.1131
CATEGORIES= lang devel
-MASTER_SITES= http://www.powerband.net.au/~david.leonard/
+MASTER_SITES= http://www.powerband.net.au/~david.leonard/ \
+ http://freshmeat.net/redir/see/45974/url_tgz/
MAINTAINER= numisemis@yahoo.com
COMMENT= Simple ECMAScript Engine (SEE)
+OPTIONS= GC "Use Boehm-Weiser garbage collection package" on \
+ OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
+ SEE_DEBUG "Internal SEE library debugging" off
+
CONFLICTS= see-devel-[0-9]*
-OPTIONS= GC "Use Boehm-Weiser garbage collection pkg" on \
- OPTIMIZED_CFLAGS "Enable some additional optimizations" off
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
-USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
+USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.pre.mk>
+.if !defined(WITH_SEE_DEBUG)
+CFLAGS+= -DNDEBUG
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -fomit-frame-pointer
.endif
-.if !defined(WITHOUT_GC)
+.if defined(WITH_GC)
LIB_DEPENDS+= gc:${PORTSDIR}/devel/boehm-gc
.else
CONFIGURE_ARGS+= --without-boehm-gc
@@ -49,7 +56,7 @@ post-patch:
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
-.for f in doc/USAGE.html AUTHORS NEWS README TODO
+.for f in doc/USAGE.html AUTHORS NEWS README TODO COPYING
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif