aboutsummaryrefslogtreecommitdiffstats
path: root/lang/see/files
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2008-01-29 17:36:03 +0800
committervanilla <vanilla@FreeBSD.org>2008-01-29 17:36:03 +0800
commit7cf4571540eb9ceeded052c5ad88b69b75efd75b (patch)
treefaa4635e4c3a6e799b109c08d46607cecdd7fecf /lang/see/files
parent4d2c107b1f35cee1a4cff46d21e0b002071cc15d (diff)
downloadfreebsd-ports-gnome-7cf4571540eb9ceeded052c5ad88b69b75efd75b.tar.gz
freebsd-ports-gnome-7cf4571540eb9ceeded052c5ad88b69b75efd75b.tar.zst
freebsd-ports-gnome-7cf4571540eb9ceeded052c5ad88b69b75efd75b.zip
Upgrade to 2.0.1131.
PR: ports/120082 Submitted by: maintainer
Diffstat (limited to 'lang/see/files')
-rw-r--r--lang/see/files/patch-include_see_Makefile.in13
-rw-r--r--lang/see/files/patch-libsee_dtoa__config.h11
-rw-r--r--lang/see/files/patch-libsee_input__utf8.c20
-rw-r--r--lang/see/files/patch-libsee_obj__Date.c38
4 files changed, 27 insertions, 55 deletions
diff --git a/lang/see/files/patch-include_see_Makefile.in b/lang/see/files/patch-include_see_Makefile.in
deleted file mode 100644
index 9633e1fa21e5..000000000000
--- a/lang/see/files/patch-include_see_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- include/see/Makefile.in.orig Wed Jan 18 14:22:20 2006
-+++ include/see/Makefile.in Wed Jul 19 19:49:40 2006
-@@ -253,8 +253,8 @@
- > inc-subst
- $(PERL) -n -e \
- 'print if s!^#define\s+(\S+)\s+(.+)!s,\\\@$$1\\\@,$$2/*$$1*/,g;!; \
-- print if s:^/\*\s*#undef\s+(\S+)\s*\*/.*:s,\\\@$$1\\\@,0/*!$$1*/,g;:; \
-- ' < $(CONFIG_HEADER) >> inc-subst
-+ print if s:^/\*\s*#undef\s+(\S+)\s*\*/.*:s,\\\@$$1\\\@,0/*!$$1*/,g;:;' \
-+ < $(CONFIG_HEADER) >> inc-subst
-
- error.h: error.h.in inc-subst
- $(PERL) -p inc-subst < $(srcdir)/error.h.in > error.h
diff --git a/lang/see/files/patch-libsee_dtoa__config.h b/lang/see/files/patch-libsee_dtoa__config.h
deleted file mode 100644
index 517f9c611103..000000000000
--- a/lang/see/files/patch-libsee_dtoa__config.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- libsee/dtoa_config.h.orig Wed Jan 18 13:51:50 2006
-+++ libsee/dtoa_config.h Tue Jan 31 16:52:54 2006
-@@ -12,7 +12,7 @@
-
- #include <see/type.h>
-
--#if defined(__i386__) || defined(__amd64__)
-+#if defined(__i386__) || defined(__amd64__) || defined(__ia64__) || defined(__alpha__)
- # define IEEE_8087
- #endif
-
diff --git a/lang/see/files/patch-libsee_input__utf8.c b/lang/see/files/patch-libsee_input__utf8.c
new file mode 100644
index 000000000000..d86e4286f7f5
--- /dev/null
+++ b/lang/see/files/patch-libsee_input__utf8.c
@@ -0,0 +1,20 @@
+--- libsee/input_utf8.c.orig Wed Jan 18 12:40:19 2006
++++ libsee/input_utf8.c Tue Dec 12 08:48:44 2006
+@@ -63,7 +63,7 @@
+
+ struct input_utf8 {
+ struct SEE_input inp;
+- const char * s;
++ const unsigned char * s;
+ };
+
+ static SEE_unicode_t
+@@ -141,7 +141,7 @@
+ inpu->inp.inputclass = &input_utf8_class;
+ inpu->inp.filename = NULL;
+ inpu->inp.first_lineno = 1;
+- inpu->s = s;
++ inpu->s = (const unsigned char *)s;
+ SEE_INPUT_NEXT((struct SEE_input *)inpu); /* prime */
+ return (struct SEE_input *)inpu;
+ }
diff --git a/lang/see/files/patch-libsee_obj__Date.c b/lang/see/files/patch-libsee_obj__Date.c
index 12c3a0614c74..320710c4078a 100644
--- a/lang/see/files/patch-libsee_obj__Date.c
+++ b/lang/see/files/patch-libsee_obj__Date.c
@@ -1,35 +1,11 @@
---- libsee/obj_Date.c.orig Wed Jan 18 13:51:50 2006
-+++ libsee/obj_Date.c Mon Mar 27 10:56:41 2006
-@@ -2167,20 +2167,12 @@
- DaylightSavingTA(t)
+--- libsee/obj_Date.c.orig Sun May 7 06:43:55 2006
++++ libsee/obj_Date.c Tue Sep 5 09:11:09 2006
+@@ -335,7 +335,7 @@
+ struct SEE_interpreter *interp;
SEE_number_t t;
{
-- SEE_number_t ysec = t - TimeFromYear((SEE_number_t)YearFromTime(t));
-- int ily = InLeapYear(t);
-- int wstart = WeekDay(TimeFromYear((SEE_number_t)YearFromTime(t)));
-- int equiv_year = yearmap[ily][wstart];
- struct tm tm;
- time_t dst_time, nodst_time;
-+ time_t tt;
-+ tt=t/1000;
-+ tm=*localtime(&tt);
-
-- memset(&tm, 0, sizeof tm);
-- tm.tm_sec = SecFromTime(ysec);
-- tm.tm_min = MinFromTime(ysec);
-- tm.tm_hour = HourFromTime(ysec);
-- tm.tm_mday = DateFromTime(ysec);
-- tm.tm_mon = MonthFromTime(ysec) - 1;
-- tm.tm_year = equiv_year - 1900;
- tm.tm_isdst = -1;
-
- if (tm.tm_isdst == 0) return 0;
-@@ -2189,7 +2181,7 @@
- tm.tm_isdst = 0;
- nodst_time = mktime(&tm);
-
-- return (dst_time - nodst_time) * 1000;
-+ return -(dst_time - nodst_time) * 1000;
+- return t + LocalTZA(interp) + DaylightSavingTA(interp, t);
++ return t + LocalTZA(interp) - DaylightSavingTA(interp, t);
}
- static void
+ /*