aboutsummaryrefslogtreecommitdiffstats
path: root/lang/seed7
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-05-10 20:54:35 +0800
committergahr <gahr@FreeBSD.org>2013-05-10 20:54:35 +0800
commitbd6c2bb74b4005dd51ed0b57782c5f64561e28f6 (patch)
treeb6c0220ffe1da6d0a3bd488eb6b574a49b72b755 /lang/seed7
parent550daa24a9c4bb2105480269cae5ed9eb95541b2 (diff)
downloadfreebsd-ports-gnome-bd6c2bb74b4005dd51ed0b57782c5f64561e28f6.tar.gz
freebsd-ports-gnome-bd6c2bb74b4005dd51ed0b57782c5f64561e28f6.tar.zst
freebsd-ports-gnome-bd6c2bb74b4005dd51ed0b57782c5f64561e28f6.zip
- Update to 05_20130505
Changes: * Functions to compare arrays (compare, <, >, <=, >=) have been added to the library array.s7i. * In seed7_05.s7i the functions hashCode and compare have been defined for enum types. * In the library bigrat.s7i the operator parse has been improved. Now the parse operator accepts decimal numbers with repeating decimals. * The function integer has been added to the library integer.s7i. This function converts a numeric string, with a specified radix, to an integer. * The function bigInteger has been added to the library bigint.s7i. This function converts a numeric string, with a specified radix, to a bigInteger. * The files encoding.s7i, gethttp.s7i, scanfile.s7i, scanstri.s7i, xml_ent.s7i and bas7.sd7 have been changed to use the new function integer instead of toInt (toInt was an undocumented internal function). * Checks for the function integer have been added to chkint.sd7. * Checks for the function bigInteger have been added to chkbig.sd7. * The operator sci has been added to to the library complex.s7i. This operater converts a complex to a string in scientific notation. * The compiler (s7c) has been improved to support the actions BIG_PARSE_BASED, TYP_CMP, ENU_CPY, ENU_CREATE and GEN_DESTR. * The memory management in the interpreter has been improved. Now it is possible that a destructor is called and the object memory is not freed. This is used to free the memory of struct objects only, when the usage_count reaches zero. * The UNUSED flag was defined in data.h and used to monitor if the object memory can be freed. * The compiler has been improved to call the destructor for local interface objects (In process_local_declaration process_destr_call is called for INTERFACEOBJECT objects). * The compiler has been improved to initialize set constants, that are part of a data structure (In walk_const_list SETOBJECT objects are added to set_const_table). * The runtime library has been improved to use the action GEN_DESTR instead of PRC_NOOP as destructor for integer and other simple data types.
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile13
-rw-r--r--lang/seed7/distinfo4
2 files changed, 5 insertions, 12 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index fc5e0a6cef26..5a0db321048c 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20130421
+DISTVERSION= 05_20130505
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -36,12 +36,6 @@ PORTDOCS= *
.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800000
-BROKEN= does not compile
-.endif
-
.if ${OSVERSION} >= 1000024 || ${CC} == clang
MAKEFILE= mk_clang.mak
.else
@@ -51,7 +45,6 @@ MAKEFILE= makefile
post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;' ${WRKSRC}/makefile ${WRKSRC}/mk_clang.mak
${REINPLACE_CMD} -e '/FLOATTYPE_DOUBLE/s|undef|define|' ${WRKSRC}/config.h
-# ${REINPLACE_CMD} -i '' -e 's|./s7|${PREFIX}/bin/s7|g' ${WRKSRC}/../prg/chk_all.sd7
do-install:
# install interpreter and compiler
@@ -71,7 +64,7 @@ do-install:
cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
.endif
# install PORTEXAMPLES
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${INSTALL} -d ${EXAMPLESDIR}
cd ${WRKSRC}/../prg && ${COPYTREE_SHARE} '*.dna *.sd7 *.dat *.s7i' ${EXAMPLESDIR}
.endif
@@ -82,4 +75,4 @@ do-install:
regression-test: build
cd ${WRKSRC} && ${GMAKE} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index d5534edf217f..b7b4d02e9052 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20130421.tgz) = 0d2752285844726c3cd24221dd1fbc64f95efb2f94c2b14145972e68f4d38eab
-SIZE (seed7_05_20130421.tgz) = 1864737
+SHA256 (seed7_05_20130505.tgz) = b2b70e1f5922f990fe0fd9cbc0abaaed8219e660c740ec6277572ec397e912e3
+SIZE (seed7_05_20130505.tgz) = 1869517