aboutsummaryrefslogtreecommitdiffstats
path: root/lang/slib
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-10-19 08:07:01 +0800
committerswills <swills@FreeBSD.org>2018-10-19 08:07:01 +0800
commit3e9ff3f962d71e1864ece9f4cf9c13563a53825b (patch)
treed76c85b216a54ae6b7dcd147ce51d539520431f7 /lang/slib
parentcca21340b951f750b8551cd2c7052f9294c22d3c (diff)
downloadfreebsd-ports-gnome-3e9ff3f962d71e1864ece9f4cf9c13563a53825b.tar.gz
freebsd-ports-gnome-3e9ff3f962d71e1864ece9f4cf9c13563a53825b.tar.zst
freebsd-ports-gnome-3e9ff3f962d71e1864ece9f4cf9c13563a53825b.zip
lang/slib:
PR: 232336
Diffstat (limited to 'lang/slib')
-rw-r--r--lang/slib/Makefile17
-rw-r--r--lang/slib/distinfo5
-rw-r--r--lang/slib/files/patch-color.txi84
-rw-r--r--lang/slib/files/patch-colornam.txi14
-rw-r--r--lang/slib/files/patch-dbutil.txi14
-rw-r--r--lang/slib/files/patch-determ.txi18
-rw-r--r--lang/slib/files/patch-dirs.txi21
-rw-r--r--lang/slib/files/patch-glob.txi24
-rw-r--r--lang/slib/files/patch-grapheps.txi38
-rw-r--r--lang/slib/files/patch-phil-spc.txi25
-rw-r--r--lang/slib/files/patch-pnm.txi14
-rw-r--r--lang/slib/files/patch-random.txi14
-rw-r--r--lang/slib/files/patch-schmooz.texi13
-rw-r--r--lang/slib/files/patch-slib.texi484
-rw-r--r--lang/slib/files/patch-solid.txi14
-rw-r--r--lang/slib/files/patch-xml-parse.txi14
-rw-r--r--lang/slib/pkg-plist5
17 files changed, 14 insertions, 804 deletions
diff --git a/lang/slib/Makefile b/lang/slib/Makefile
index abea863a1958..c275870f8b6e 100644
--- a/lang/slib/Makefile
+++ b/lang/slib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= slib
-PORTVERSION= 3b4
+PORTVERSION= 3b5
CATEGORIES= lang scheme
MASTER_SITES= http://groups.csail.mit.edu/mac/ftpdir/scm/ \
http://groups.csail.mit.edu/mac/ftpdir/scm/OLD/
@@ -10,10 +10,15 @@ MASTER_SITES= http://groups.csail.mit.edu/mac/ftpdir/scm/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Portable scheme library
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= gmake makeinfo
+
ALL_TARGET= slib.info
INFO= slib
NO_ARCH= yes
+PORTDOCS= ANNOUNCE ChangeLog FAQ README
OPTIONS_DEFINE= DOCS
@@ -23,14 +28,12 @@ post-patch:
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/*.scm ${WRKSRC}/*.init ${WRKSRC}/*.txt \
- ${WRKSRC}/*.xyz ${WRKSRC}/*.ps ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} ; ${INSTALL_DATA} *.scm *.init *.txt \
+ *.xyz *.ps ${STAGEDIR}${DATADIR})
${INSTALL_DATA} ${WRKSRC}/slib.info ${STAGEDIR}${PREFIX}/info
-do-install-DOCS-on:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ANNOUNCE ChangeLog FAQ README
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/lang/slib/distinfo b/lang/slib/distinfo
index f7788a6e9cc2..d4160c23790f 100644
--- a/lang/slib/distinfo
+++ b/lang/slib/distinfo
@@ -1,2 +1,3 @@
-SHA256 (slib-3b4.tar.gz) = 9f7c50cb07ba996917aa1b15eca6392d0215ccbdfdf84f68486a23adc7f1d7a6
-SIZE (slib-3b4.tar.gz) = 974395
+TIMESTAMP = 1539733415
+SHA256 (slib-3b5.tar.gz) = ea26e5170c6db6d6c69e4aaf91e9b1c9619174fc92d5dc63c71fff2a935e51ba
+SIZE (slib-3b5.tar.gz) = 987735
diff --git a/lang/slib/files/patch-color.txi b/lang/slib/files/patch-color.txi
deleted file mode 100644
index ca65b8b36d5c..000000000000
--- a/lang/slib/files/patch-color.txi
+++ /dev/null
@@ -1,84 +0,0 @@
---- color.txi.orig 2013-05-12 04:47:55 UTC
-+++ color.txi
-@@ -107,8 +107,9 @@
- @defun color:l*a*b* L* a* b* white-point
-
- Returns the L*a*b* color composed of @var{L*}, @var{a*}, @var{b*} with @var{white-point}.
-+@end defun
-
--@defunx color:l*a*b* L* a* b*
-+@defun color:l*a*b* L* a* b*
- Returns the L*a*b* color composed of @var{L*}, @var{a*}, @var{b*}. If the coordinates
- do not encode a valid L*a*b* color, then an error is signaled.
- @end defun
-@@ -117,8 +118,9 @@
- @defun color->l*a*b* color white-point
-
- Returns the list of 3 numbers encoding @var{color} in L*a*b* with @var{white-point}.
-+@end defun
-
--@defunx color->l*a*b* color
-+@defun color->l*a*b* color
- Returns the list of 3 numbers encoding @var{color} in L*a*b*.
- @end defun
-
-@@ -138,8 +140,9 @@
- @defun color:l*u*v* L* u* v* white-point
-
- Returns the L*u*v* color composed of @var{L*}, @var{u*}, @var{v*} with @var{white-point}.
-+@end defun
-
--@defunx color:l*u*v* L* u* v*
-+@defun color:l*u*v* L* u* v*
- Returns the L*u*v* color composed of @var{L*}, @var{u*}, @var{v*}. If the coordinates
- do not encode a valid L*u*v* color, then an error is signaled.
- @end defun
-@@ -148,8 +151,9 @@
- @defun color->l*u*v* color white-point
-
- Returns the list of 3 numbers encoding @var{color} in L*u*v* with @var{white-point}.
-+@end defun
-
--@defunx color->l*u*v* color
-+@defun color->l*u*v* color
- Returns the list of 3 numbers encoding @var{color} in L*u*v*.
- @end defun
-
-@@ -206,8 +210,9 @@
- @defun color:l*c*h L* C* h white-point
-
- Returns the L*C*h color composed of @var{L*}, @var{C*}, @var{h} with @var{white-point}.
-+@end defun
-
--@defunx color:l*c*h L* C* h
-+@defun color:l*c*h L* C* h
- Returns the L*C*h color composed of @var{L*}, @var{C*}, @var{h}. If the coordinates
- do not encode a valid L*C*h color, then an error is signaled.
- @end defun
-@@ -216,8 +221,9 @@
- @defun color->l*c*h color white-point
-
- Returns the list of 3 numbers encoding @var{color} in L*C*h with @var{white-point}.
-+@end defun
-
--@defunx color->l*c*h color
-+@defun color->l*c*h color
- Returns the list of 3 numbers encoding @var{color} in L*C*h.
- @end defun
-
-@@ -326,11 +332,13 @@
- @defun color:e-srgb 10 r g b
-
- Returns the e-sRGB10 color composed of integers @var{r}, @var{g}, @var{b}.
-+@end defun
-
--@defunx color:e-srgb 12 r g b
-+@defun color:e-srgb 12 r g b
- Returns the e-sRGB12 color composed of integers @var{r}, @var{g}, @var{b}.
-+@end defun
-
--@defunx color:e-srgb 16 r g b
-+@defun color:e-srgb 16 r g b
- Returns the e-sRGB16 color composed of integers @var{r}, @var{g}, @var{b}.
- If the coordinates do not encode a valid e-sRGB color, then an error
- is signaled.
diff --git a/lang/slib/files/patch-colornam.txi b/lang/slib/files/patch-colornam.txi
deleted file mode 100644
index f0b9670bf409..000000000000
--- a/lang/slib/files/patch-colornam.txi
+++ /dev/null
@@ -1,14 +0,0 @@
---- colornam.txi.orig 2013-05-12 04:47:55 UTC
-+++ colornam.txi
-@@ -56,9 +56,10 @@
- @var{name} a table therein. The database will be opened as
- @var{base-table-type}. @code{color-dictionary} returns the read-only table @var{name} in database
- @var{name} if it exists; #f otherwise.
-+@end defun
-
-
--@defunx color-dictionary name rdb
-+@defun color-dictionary name rdb
-
- @var{rdb} must be an open relational database or a string naming a relational
- database file; and the symbol @var{name} a table therein. @code{color-dictionary} returns the
diff --git a/lang/slib/files/patch-dbutil.txi b/lang/slib/files/patch-dbutil.txi
deleted file mode 100644
index 1be7b4aef441..000000000000
--- a/lang/slib/files/patch-dbutil.txi
+++ /dev/null
@@ -1,14 +0,0 @@
---- dbutil.txi.orig 2013-05-12 04:47:55 UTC
-+++ dbutil.txi
-@@ -85,9 +85,10 @@
-
- Returns an open relational database associated with @var{rdb}. The
- database will be opened with base-table type @var{base-table-type}).
-+@end defun
-
-
--@defunx open-database rdb
-+@defun open-database rdb
- Returns an open relational database associated with @var{rdb}.
- @code{open-database} will attempt to deduce the correct base-table-type.
- @end defun
diff --git a/lang/slib/files/patch-determ.txi b/lang/slib/files/patch-determ.txi
deleted file mode 100644
index 409fbc6cff1f..000000000000
--- a/lang/slib/files/patch-determ.txi
+++ /dev/null
@@ -1,18 +0,0 @@
---- determ.txi.orig 2013-05-12 04:47:55 UTC
-+++ determ.txi
-@@ -53,11 +53,13 @@
- @defun matrix:product m1 m2
-
- Returns the product of matrices @var{m1} and @var{m2}.
-+@end defun
-
--@defunx matrix:product m1 z
-+@defun matrix:product m1 z
- Returns matrix @var{m1} times scalar @var{z}.
-+@end defun
-
--@defunx matrix:product z m1
-+@defun matrix:product z m1
- Returns matrix @var{m1} times scalar @var{z}.
- @end defun
-
diff --git a/lang/slib/files/patch-dirs.txi b/lang/slib/files/patch-dirs.txi
deleted file mode 100644
index 48083bb7d090..000000000000
--- a/lang/slib/files/patch-dirs.txi
+++ /dev/null
@@ -1,21 +0,0 @@
---- dirs.txi.orig 2013-05-12 04:47:55 UTC
-+++ dirs.txi
-@@ -26,14 +26,15 @@
- each file in @var{directory}. The dynamic order in which @var{proc} is
- applied to the filenames is unspecified. The value returned by
- @samp{directory-for-each} is unspecified.
-+@end defun
-
-
--@defunx directory-for-each proc directory pred
-+@defun directory-for-each proc directory pred
- Applies @var{proc} only to those filenames for which the procedure
- @var{pred} returns a non-false value.
-+@end defun
-
--
--@defunx directory-for-each proc directory match
-+@defun directory-for-each proc directory match
- Applies @var{proc} only to those filenames for which
- @code{(filename:match?? @var{match})} would return a non-false value
- (@pxref{Filenames, , , slib, SLIB}).
diff --git a/lang/slib/files/patch-glob.txi b/lang/slib/files/patch-glob.txi
deleted file mode 100644
index 81a74b70bcb6..000000000000
--- a/lang/slib/files/patch-glob.txi
+++ /dev/null
@@ -1,24 +0,0 @@
---- glob.txi.orig 2013-05-12 04:47:55 UTC
-+++ glob.txi
-@@ -83,18 +83,16 @@
- @end example
-
-
--@defun call-with-tmpnam proc k
--
--
--@defunx call-with-tmpnam proc
-+@defun call-with-tmpnam proc
- Calls @var{proc} with @var{k} arguments, strings returned by successive calls to
- @code{tmpnam}.
- If @var{proc} returns, then any files named by the arguments to @var{proc} are
- deleted automatically and the value(s) yielded by the @var{proc} is(are)
- returned. @var{k} may be ommited, in which case it defaults to @code{1}.
-+@end defun
-
-
--@defunx call-with-tmpnam proc suffix1 @dots{}
-+@defun call-with-tmpnam proc suffix1 @dots{}
- Calls @var{proc} with strings returned by successive calls to @code{tmpnam},
- each with the corresponding @var{suffix} string appended.
- If @var{proc} returns, then any files named by the arguments to @var{proc} are
diff --git a/lang/slib/files/patch-grapheps.txi b/lang/slib/files/patch-grapheps.txi
deleted file mode 100644
index 6f40f658313d..000000000000
--- a/lang/slib/files/patch-grapheps.txi
+++ /dev/null
@@ -1,38 +0,0 @@
---- grapheps.txi.orig 2013-05-12 04:47:55 UTC
-+++ grapheps.txi
-@@ -251,11 +251,13 @@
- @defun set-linedash j k
-
- Lines are drawn @var{j}-on @var{k}-off.
-+@end defun
-
--@defunx set-linedash j
-+@defun set-linedash j
- Lines are drawn @var{j}-on @var{j}-off.
-+@end defun
-
--@defunx set-linedash
-+@defun set-linedash
- Turns off dashing.
- @end defun
-
-@@ -432,15 +434,17 @@
- encapsulated PostScript graph of the function of one argument @var{func}
- over the range @var{x1} to @var{x2}. If the optional integer argument @var{npts} is
- supplied, it specifies the number of points to evaluate @var{func} at.
-+@end defun
-
-
--@defunx plot x1 x2 npts func1 func2 @dots{}
-+@defun plot x1 x2 npts func1 func2 @dots{}
- Creates and displays an encapsulated PostScript graph of the
- one-argument functions @var{func1}, @var{func2}, ... over the range
- @var{x1} to @var{x2} at @var{npts} points.
-+@end defun
-
-
--@defunx plot coords x-label y-label
-+@defun plot coords x-label y-label
- @var{coords} is a list or vector of coordinates, lists of x and y
- coordinates. @var{x-label} and @var{y-label} are strings with which
- to label the x and y axes.
diff --git a/lang/slib/files/patch-phil-spc.txi b/lang/slib/files/patch-phil-spc.txi
deleted file mode 100644
index a94cc7be86b1..000000000000
--- a/lang/slib/files/patch-phil-spc.txi
+++ /dev/null
@@ -1,25 +0,0 @@
---- phil-spc.txi.orig 2013-05-12 04:47:55 UTC
-+++ phil-spc.txi
-@@ -39,9 +39,10 @@
- Returns a list of @var{rank} integer coordinates corresponding to exact
- non-negative integer @var{scalar}. The lists returned by @code{integer->hilbert-coordinates} for @var{scalar} arguments
- 0 and 1 will differ in the first element.
-+@end defun
-
-
--@defunx integer->hilbert-coordinates scalar rank k
-+@defun integer->hilbert-coordinates scalar rank k
-
- @var{scalar} must be a nonnegative integer of no more than
- @code{@var{rank}*@var{k}} bits.
-@@ -80,8 +81,9 @@
- @defun integer->gray-code k
- Converts @var{k} to a Gray code of the same @code{integer-length} as
- @var{k}.
-+@end defun
-
--@defunx gray-code->integer k
-+@defun gray-code->integer k
- Converts the Gray code @var{k} to an integer of the same
- @code{integer-length} as @var{k}.
-
diff --git a/lang/slib/files/patch-pnm.txi b/lang/slib/files/patch-pnm.txi
deleted file mode 100644
index c5cb14a1dce5..000000000000
--- a/lang/slib/files/patch-pnm.txi
+++ /dev/null
@@ -1,14 +0,0 @@
---- pnm.txi.orig 2013-05-12 04:47:55 UTC
-+++ pnm.txi
-@@ -48,9 +48,10 @@
- @cindex portable bitmap graphics
- @var{array}. @var{array} must be the correct size and type for
- @var{path}. @var{array} is returned.
-+@end defun
-
-
--@defunx pnm:image-file->array path
-+@defun pnm:image-file->array path
-
- @code{pnm:image-file->array} creates and returns an array with the
- @dfn{portable bitmap graphics} file named by @var{path} read into it.
diff --git a/lang/slib/files/patch-random.txi b/lang/slib/files/patch-random.txi
deleted file mode 100644
index 8b445d99a0e2..000000000000
--- a/lang/slib/files/patch-random.txi
+++ /dev/null
@@ -1,14 +0,0 @@
---- random.txi.orig 2013-05-12 04:47:55 UTC
-+++ random.txi
-@@ -32,9 +32,10 @@
- @defun copy-random-state state
-
- Returns a new copy of argument @var{state}.
-+@end defun
-
-
--@defunx copy-random-state
-+@defun copy-random-state
- Returns a new copy of @code{*random-state*}.
- @end defun
-
diff --git a/lang/slib/files/patch-schmooz.texi b/lang/slib/files/patch-schmooz.texi
deleted file mode 100644
index 99149bde1f3a..000000000000
--- a/lang/slib/files/patch-schmooz.texi
+++ /dev/null
@@ -1,13 +0,0 @@
---- schmooz.texi.orig 2001-10-15 04:34:18 UTC
-+++ schmooz.texi
-@@ -17,8 +17,9 @@
- top-level comments containing schmooz commands from @var{filename}.scm
- and writes the converted Texinfo source to a file named
- @var{filename}.txi.
-+@end deffn
-
--@deffnx Procedure schmooz filename@r{.texi} @dots{}
-+@deffn Procedure schmooz filename@r{.texi} @dots{}
- @deffnx Procedure schmooz filename@r{.tex} @dots{}
- @deffnx Procedure schmooz filename@r{.txi} @dots{}
- @var{Filename} should be a string naming an existing file containing
diff --git a/lang/slib/files/patch-slib.texi b/lang/slib/files/patch-slib.texi
deleted file mode 100644
index 546871996d2c..000000000000
--- a/lang/slib/files/patch-slib.texi
+++ /dev/null
@@ -1,484 +0,0 @@
---- slib.texi.orig 2012-10-23 21:17:29 UTC
-+++ slib.texi
-@@ -812,11 +812,13 @@
- Displays the information of @code{(slib:report-version)} followed by
- almost all the information neccessary for submitting a problem report.
- An unspecified value is returned.
-+@end defun
-
--@defunx slib:report #t
-+@defun slib:report #t
- provides a more verbose listing.
-+@end defun
-
--@defunx slib:report filename
-+@defun slib:report filename
- Writes the verbose report to file @file{filename}.
-
- @example
-@@ -940,8 +942,9 @@
- current position of the character in @var{port} which will next be
- read or written. If the implementation does not support
- file-position, then @code{#f} is returned.
-+@end defun
-
--@defunx file-position port k
-+@defun file-position port k
- @var{port} must be open to a file. @code{file-position} sets the
- current position in @var{port} which will next be read or written. If
- successful, @code{#t} is returned; otherwise @code{file-position}
-@@ -3400,7 +3403,7 @@
- A character that specifies the conversion to be applied.
- @end itemize
-
--@subsubsection Exact Conversions
-+Exact Conversions
-
- @table @asis
- @item @samp{b}, @samp{B}
-@@ -3426,7 +3429,7 @@
- digits @samp{0123456789ABCDEF}.
- @end table
-
--@subsubsection Inexact Conversions
-+Inexact Conversions
-
- @table @asis
- @item @samp{f}
-@@ -3451,7 +3454,7 @@
-
- @end table
-
--@subsubsection Other Conversions
-+Other Conversions
- @table @asis
- @item @samp{c}
- Print a single character. The @samp{-} flag is the only one which can
-@@ -4592,11 +4595,13 @@
-
- @defun tzset
- Returns the default time-zone.
-+@end defun
-
--@defunx tzset tz
-+@defun tzset tz
- Sets (and returns) the default time-zone to @var{tz}.
-+@end defun
-
--@defunx tzset TZ-string
-+@defun tzset TZ-string
- Sets (and returns) the default time-zone to that specified by
- @var{TZ-string}.
-
-@@ -4670,11 +4675,13 @@
-
- @defun gmtime caltime
- Converts the calendar time @var{caltime} to UTC and returns it.
-+@end defun
-
--@defunx localtime caltime tz
-+@defun localtime caltime tz
- Returns @var{caltime} converted to UTC relative to timezone @var{tz}.
-+@end defun
-
--@defunx localtime caltime
-+@defun localtime caltime
- converts the calendar time @var{caltime} to a vector of integers
- expressed relative to the user's time zone. @code{localtime} sets the
- variable @var{*timezone*} with the difference between Coordinated
-@@ -4686,12 +4693,14 @@
- @defun gmktime univtime
- Converts a vector of integers in GMT Coordinated Universal Time (UTC)
- format to a calendar time.
-+@end defun
-
--@defunx mktime univtime
-+@defun mktime univtime
- Converts a vector of integers in local Coordinated Universal Time (UTC)
- format to a calendar time.
-+@end defun
-
--@defunx mktime univtime tz
-+@defun mktime univtime tz
- Converts a vector of integers in Coordinated Universal Time (UTC) format
- (relative to time-zone @var{tz})
- to calendar time.
-@@ -5096,8 +5105,9 @@
- corresponding to each bit of the non-negative integer @var{k}. #t is
- coded for each 1; #f for 0. The @var{len} argument defaults to
- @code{(integer-length @var{k})}.
-+@end defun
-
--@defunx list->integer list
-+@defun list->integer list
- @code{list->integer} returns an integer formed from the booleans in the
- list @var{list}, which must be a list of booleans. A 1 bit is coded for
- each #t; a 0 bit for #f.
-@@ -5519,8 +5529,9 @@
- (cksum (in-vicinity (library-vicinity) "ratize.scm"))
- @result{} 157103930
- @end example
-+@end defun
-
--@defunx cksum port
-+@defun cksum port
- Computes the checksum of the bytes read from @var{port} until the
- end-of-file.
-
-@@ -5539,8 +5550,9 @@
- @defun crc16 file
-
- Computes the USB data-packet (16-bit) CRC of @var{file}.
-+@end defun
-
--@defunx crc16 port
-+@defun crc16 port
- Computes the USB data-packet (16-bit) CRC of the bytes read from
- @var{port} until the end-of-file.
-
-@@ -5552,8 +5564,9 @@
- @defun crc5 file
-
- Computes the USB token (5-bit) CRC of @var{file}.
-+@end defun
-
--@defunx crc5 port
-+@defun crc5 port
- Computes the USB token (5-bit) CRC of the bytes read from
- @var{port} until the end-of-file.
-
-@@ -5747,8 +5760,9 @@
-
- @defun color? obj
- Returns #t if @var{obj} is a color.
-+@end defun
-
--@defunx color? obj typ
-+@defun color? obj typ
- Returns #t if @var{obj} is a color of color-space @var{typ}. The symbol
- @var{typ} must be one of:
-
-@@ -5961,14 +5975,16 @@
- Loads the Spectral Tristimulus Values
- @cite{CIE 1964 Supplementary Standard Colorimetric Observer},
- defining @var{cie:x-bar}, @var{cie:y-bar}, and @var{cie:z-bar}.
-+@end deftp
-
--@deftpx {Feature} cie1931
-+@deftp {Feature} cie1931
- @ftindex cie1931
- Loads the Spectral Tristimulus Values
- @cite{CIE 1931 Supplementary Standard Colorimetric Observer},
- defining @var{cie:x-bar}, @var{cie:y-bar}, and @var{cie:z-bar}.
-+@end deftp
-
--@deftpx {Feature} ciexyz
-+@deftp {Feature} ciexyz
- @ftindex ciexyz
- Requires Spectral Tristimulus Values, defaulting to cie1931,
- defining @var{cie:x-bar}, @var{cie:y-bar}, and @var{cie:z-bar}.
-@@ -6037,8 +6053,9 @@
- computes the CIEXYZ(1931) values for the spectrum returned by @var{proc}
- when called with arguments from 380e-9 to 780e-9, the wavelength in
- meters.
-+@end defun
-
--@defunx spectrum->XYZ spectrum x1 x2
-+@defun spectrum->XYZ spectrum x1 x2
- @var{x1} and @var{x2} must be positive real numbers specifying the
- wavelengths (in meters) corresponding to the zeroth and last elements of
- vector or list @var{spectrum}. @code{spectrum->XYZ} returns the
-@@ -6160,8 +6177,9 @@
- scales each chromaticity so it sums to 1 or less; and divides the
- @var{Y} values by the maximum @var{Y} in the dataset, so all lie between
- 0 and 1.
-+@end defun
-
--@defunx xyY:normalize-colors colors n
-+@defun xyY:normalize-colors colors n
- If @var{n} is positive real, then @code{xyY:normalize-colors} divides
- the @var{Y} values by @var{n} times the maximum @var{Y} in the dataset.
-
-@@ -6206,8 +6224,9 @@
-
- @defun L*a*b*:DE* lab1 lab2
- Returns the Euclidean distance between @var{lab1} and @var{lab2}.
-+@end defun
-
--@defunx CIE:DE* color1 color2 white-point
-+@defun CIE:DE* color1 color2 white-point
- @defunx CIE:DE* color1 color2
- Returns the Euclidean distance in L*a*b* space between @var{color1} and
- @var{color2}.
-@@ -6725,8 +6744,9 @@
- @var{sub-op2}, respectively. The argument @var{reduction} is a
- procedure accepting 2 arguments which will be lists whose @code{car}s
- are @var{sub-op1} and @var{sub-op2}.
-+@end defun
-
--@defunx cring:define-rule op sub-op1 'identity reduction
-+@defun cring:define-rule op sub-op1 'identity reduction
- Defines a rule for the case when the operation represented by symbol
- @var{op} is applied to a list whose @code{car} is @var{sub-op1}, and
- some other argument. @var{Reduction} will be called with the list whose
-@@ -7211,8 +7231,9 @@
- returns the key-list identifying the lowest record higher than
- @var{key1} @var{key2} @dots{} which is stored in the relational-table;
- or false if no higher record is present.
-+@end defop
-
--@defopx {Operation} {relational-table} isam-next column-name
-+@defop {Operation} {relational-table} isam-next column-name
- The symbol @var{column-name} names a key field. In the list returned
- by @code{isam-next}, that field, or a field to its left, will be
- changed. This allows one to skip over less significant key fields.
-@@ -7223,8 +7244,9 @@
- returns the key-list identifying the highest record less than
- @var{key1} @var{key2} @dots{} which is stored in the relational-table;
- or false if no lower record is present.
-+@end defop
-
--@defopx {Operation} {relational-table} isam-prev column-name
-+@defop {Operation} {relational-table} isam-prev column-name
- The symbol @var{column-name} names a key field. In the list returned
- by @code{isam-next}, that field, or a field to its left, will be
- changed. This allows one to skip over less significant key fields.
-@@ -7264,8 +7286,9 @@
- names, or type names respectively for this table. These 4 methods are
- different from the others in that the list is returned, rather than a
- procedure to obtain the list.
-+@end defop
-
--@defopx {Operation} {relational-table} primary-limit
-+@defop {Operation} {relational-table} primary-limit
- Returns the number of primary keys fields in the relations in this
- table.
- @end defop
-@@ -7398,16 +7421,19 @@
- supplied, @code{open-command-database} will attempt to deduce the correct
- base-table-type. If the database can not be opened or if it lacks the
- @code{*commands*} table, @code{#f} is returned.
-+@end defun
-
--@defunx open-command-database! filename
-+@defun open-command-database! filename
- @defunx open-command-database! filename base-table-type
- Returns @emph{mutable} open enhanced relational database @dots{}
-+@end defun
-
--@defunx open-command-database database
-+@defun open-command-database database
- Returns @var{database} if it is an immutable relational database; #f
- otherwise.
-+@end defun
-
--@defunx open-command-database! database
-+@defun open-command-database! database
- Returns @var{database} if it is a mutable relational database; #f
- otherwise.
- @end defun
-@@ -7928,32 +7954,31 @@
-
- Prints the names of all the tables in @var{database} and sets browse's
- default to @var{database}.
--
--@deffnx {Procedure} browse
-+@end deffn
-+@deffn {Procedure} browse
-
- Prints the names of all the tables in the default database.
--
--@deffnx {Procedure} browse table-name
-+@end deffn
-+@deffn {Procedure} browse table-name
-
- For each record of the table named by the symbol @var{table-name},
- prints a line composed of all the field values.
--
--@deffnx {Procedure} browse pathname
-+@end deffn
-+@deffn {Procedure} browse pathname
-
- Opens the database named by the string @var{pathname}, prints the names
- of all its tables, and sets browse's default to the database.
--
--@deffnx {Procedure} browse database table-name
-+@end deffn
-+@deffn {Procedure} browse database table-name
-
- Sets browse's default to @var{database} and prints the records of the
- table named by the symbol @var{table-name}.
--
--@deffnx {Procedure} browse pathname table-name
-+@end deffn
-+@deffn {Procedure} browse pathname table-name
-
- Opens the database named by the string @var{pathname} and sets browse's
- default to it; @code{browse} prints the records of the table named by
- the symbol @var{table-name}.
--
- @end deffn
-
-
-@@ -8576,8 +8601,9 @@
- describing the columns of a new base table in this database, otherwise
- returns @code{#f}. For the fields and layout of descriptor tables,
- @xref{Catalog Representation}.
-+@end defop
-
--@defopx {Operation} {relational-database} create-table table-name table-desc-name
-+@defop {Operation} {relational-database} create-table table-name table-desc-name
- Returns a methods procedure for a new (open) relational table with
- columns as described by @var{table-desc-name}, otherwise returns
- @code{#f}.
-@@ -9900,14 +9926,16 @@
- @defun list-of?? predicate
- Returns a predicate which returns true if its argument is a list every
- element of which satisfies @var{predicate}.
-+@end defun
-
--@defunx list-of?? predicate low-bound high-bound
-+@defun list-of?? predicate low-bound high-bound
- @var{low-bound} and @var{high-bound} are non-negative integers.
- @code{list-of??} returns a predicate which returns true if its argument
- is a list of length between @var{low-bound} and @var{high-bound}
- (inclusive); every element of which satisfies @var{predicate}.
-+@end defun
-
--@defunx list-of?? predicate bound
-+@defun list-of?? predicate bound
- @var{bound} is an integer. If @var{bound} is negative, @code{list-of??}
- returns a predicate which returns true if its argument is a list of
- length greater than @code{(- @var{bound})}; every element of which
-@@ -10684,16 +10712,19 @@
- @deffn {Procedure} find-string-from-port? str in-port max-no-chars
- Looks for a string @var{str} within the first @var{max-no-chars} chars
- of the input port @var{in-port}.
-+@end deffn
-
--@deffnx {Procedure} find-string-from-port? str in-port
-+@deffn {Procedure} find-string-from-port? str in-port
- When called with two arguments, the search span is limited by the end of
- the input stream.
-+@end deffn
-
--@deffnx {Procedure} find-string-from-port? str in-port char
-+@deffn {Procedure} find-string-from-port? str in-port char
- Searches up to the first occurrence of character @var{char} in
- @var{str}.
-+@end deffn
-
--@deffnx {Procedure} find-string-from-port? str in-port proc
-+@deffn {Procedure} find-string-from-port? str in-port proc
- Searches up to the first occurrence of the procedure @var{proc}
- returning non-false when called with a character (from @var{in-port})
- argument.
-@@ -11635,12 +11666,14 @@
- @deffn {Procedure} trace-all file @dots{}
- Traces (@pxref{Trace}) all procedures @code{define}d at top-level in
- @file{file} @dots{}.
-+@end deffn
-
--@deffnx {Procedure} track-all file @dots{}
-+@deffn {Procedure} track-all file @dots{}
- Tracks (@pxref{Trace}) all procedures @code{define}d at top-level in
- @file{file} @dots{}.
-+@end deffn
-
--@deffnx {Procedure} stack-all file @dots{}
-+@deffn {Procedure} stack-all file @dots{}
- Stacks (@pxref{Trace}) all procedures @code{define}d at top-level in
- @file{file} @dots{}.
- @end deffn
-@@ -11676,8 +11709,9 @@
- @defun continue
- Pops the topmost continuation off of the continuation stack and returns
- an unspecified value to it.
-+@end defun
-
--@defunx continue arg1 @dots{}
-+@defun continue arg1 @dots{}
- Pops the topmost continuation off of the continuation stack and returns
- @var{arg1} @dots{} to it.
- @end defun
-@@ -11685,7 +11719,9 @@
- @defmac break proc1 @dots{}
- Redefines the top-level named procedures given as arguments so that
- @code{breakpoint} is called before calling @var{proc1} @dots{}.
--@defmacx break
-+@end defmac
-+
-+@defmac break
- With no arguments, makes sure that all the currently broken identifiers
- are broken (even if those identifiers have been redefined) and returns a
- list of the broken identifiers.
-@@ -11693,7 +11729,9 @@
-
- @defmac unbreak proc1 @dots{}
- Turns breakpoints off for its arguments.
--@defmacx unbreak
-+@end defmac
-+
-+@defmac unbreak
- With no arguments, unbreaks all currently broken identifiers and returns
- a list of these formerly broken identifiers.
- @end defmac
-@@ -11768,7 +11806,9 @@
-
- @defmac trace proc1 @dots{}
- Traces the top-level named procedures given as arguments.
--@defmacx trace
-+@end defmac
-+
-+@defmac trace
- With no arguments, makes sure that all the currently traced identifiers
- are traced (even if those identifiers have been redefined) and returns a
- list of the traced identifiers.
-@@ -11776,7 +11816,8 @@
-
- @defmac track proc1 @dots{}
- Traces the top-level named procedures given as arguments.
--@defmacx track
-+@end defmac
-+@defmac track
- With no arguments, makes sure that all the currently tracked identifiers
- are tracked (even if those identifiers have been redefined) and returns
- a list of the tracked identifiers.
-@@ -11784,7 +11825,8 @@
-
- @defmac stack proc1 @dots{}
- Traces the top-level named procedures given as arguments.
--@defmacx stack
-+@end defmac
-+@defmac stack
- With no arguments, makes sure that all the currently stacked identifiers
- are stacked (even if those identifiers have been redefined) and returns
- a list of the stacked identifiers.
-@@ -11792,21 +11834,24 @@
-
- @defmac untrace proc1 @dots{}
- Turns tracing, tracking, and off for its arguments.
--@defmacx untrace
-+@end defmac
-+@defmac untrace
- With no arguments, untraces all currently traced identifiers and returns
- a list of these formerly traced identifiers.
- @end defmac
-
- @defmac untrack proc1 @dots{}
- Turns tracing, tracking, and off for its arguments.
--@defmacx untrack
-+@end defmac
-+@defmac untrack
- With no arguments, untracks all currently tracked identifiers and returns
- a list of these formerly tracked identifiers.
- @end defmac
-
- @defmac unstack proc1 @dots{}
- Turns tracing, stacking, and off for its arguments.
--@defmacx unstack
-+@end defmac
-+@defmac unstack
- With no arguments, unstacks all currently stacked identifiers and returns
- a list of these formerly stacked identifiers.
- @end defmac
diff --git a/lang/slib/files/patch-solid.txi b/lang/slib/files/patch-solid.txi
deleted file mode 100644
index 6278d57ab0fd..000000000000
--- a/lang/slib/files/patch-solid.txi
+++ /dev/null
@@ -1,14 +0,0 @@
---- solid.txi.orig 2013-05-12 04:47:55 UTC
-+++ solid.txi
-@@ -544,9 +544,10 @@
-
- @var{center} must be a list or vector of three numbers. Returns an upward
- pointing metallic arrow centered at @var{center}.
-+@end defun
-
-
--@defunx solid:arrow
-+@defun solid:arrow
- Returns an upward pointing metallic arrow centered at the origin.
- @end defun
-
diff --git a/lang/slib/files/patch-xml-parse.txi b/lang/slib/files/patch-xml-parse.txi
deleted file mode 100644
index 0010b8905ee5..000000000000
--- a/lang/slib/files/patch-xml-parse.txi
+++ /dev/null
@@ -1,14 +0,0 @@
---- xml-parse.txi.orig 2013-05-12 04:47:55 UTC
-+++ xml-parse.txi
-@@ -108,9 +108,10 @@
- @var{inc-charset}. The reading stops at the first character which is not a member
- of the set. This character is left on the stream. All the read
- characters are returned in a string.
-+@end defun
-
-
--@defunx ssax:next-token-of pred port
-+@defun ssax:next-token-of pred port
-
- Reads characters from the @var{port} for which @var{pred} (a procedure of
- one argument) returns non-#f. The reading stops at the first
diff --git a/lang/slib/pkg-plist b/lang/slib/pkg-plist
index ce614b0dfa50..7014b4884abd 100644
--- a/lang/slib/pkg-plist
+++ b/lang/slib/pkg-plist
@@ -122,6 +122,7 @@
%%DATADIR%%/repl.scm
%%DATADIR%%/require.scm
%%DATADIR%%/resenecolours.txt
+%%DATADIR%%/rmdsff.scm
%%DATADIR%%/root.scm
%%DATADIR%%/s7.init
%%DATADIR%%/saturate.txt
@@ -185,7 +186,3 @@
%%DATADIR%%/wttree.scm
%%DATADIR%%/xml-parse.scm
%%DATADIR%%/yasyn.scm
-%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/FAQ
-%%PORTDOCS%%%%DOCSDIR%%/README