aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spec.alpha
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2018-02-25 01:10:08 +0800
committerjrm <jrm@FreeBSD.org>2018-02-25 01:10:08 +0800
commit0d067ecc27db4bfba0b6bbcc4c4136d254ef15db (patch)
treebdb40d4ee9c1e0f0b745f7390ea22c0345b09005 /lang/spec.alpha
parente2341509171f345dbaf1bc34e1ae96dc9102bfa4 (diff)
downloadfreebsd-ports-gnome-0d067ecc27db4bfba0b6bbcc4c4136d254ef15db.tar.gz
freebsd-ports-gnome-0d067ecc27db4bfba0b6bbcc4c4136d254ef15db.tar.zst
freebsd-ports-gnome-0d067ecc27db4bfba0b6bbcc4c4136d254ef15db.zip
lang/spec.alpha: New port; library dependency for Clojure 1.9
PR: 224251 Submitted by: Jens Grassel <jan0sch@mykolab.com> (maintainer)
Diffstat (limited to 'lang/spec.alpha')
-rw-r--r--lang/spec.alpha/Makefile24
-rw-r--r--lang/spec.alpha/distinfo3
-rw-r--r--lang/spec.alpha/pkg-descr17
3 files changed, 44 insertions, 0 deletions
diff --git a/lang/spec.alpha/Makefile b/lang/spec.alpha/Makefile
new file mode 100644
index 000000000000..144bf584607a
--- /dev/null
+++ b/lang/spec.alpha/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= spec.alpha
+DISTVERSION= 0.1.143
+CATEGORIES= lang lisp java
+MASTER_SITES= http://repo1.maven.org/maven2/org/clojure/spec.alpha/${PORTVERSION}/
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY= # empty
+
+MAINTAINER= jan0sch@mykolab.com
+COMMENT= Clojure library to describe the structure of data and functions
+
+LICENSE= EPL
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+
+NO_BUILD= yes
+PLIST_FILES= ${JAVAJARDIR}/spec.alpha.jar
+
+do-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${STAGEDIR}${JAVAJARDIR}/spec.alpha.jar
+
+.include <bsd.port.mk>
diff --git a/lang/spec.alpha/distinfo b/lang/spec.alpha/distinfo
new file mode 100644
index 000000000000..3efe72adb59a
--- /dev/null
+++ b/lang/spec.alpha/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515256360
+SHA256 (spec.alpha-0.1.143.jar) = 4b7936302843c03399e4c8741b9239fc088528dea19c7dd330c64c2269df6080
+SIZE (spec.alpha-0.1.143.jar) = 591287
diff --git a/lang/spec.alpha/pkg-descr b/lang/spec.alpha/pkg-descr
new file mode 100644
index 000000000000..fa7128643399
--- /dev/null
+++ b/lang/spec.alpha/pkg-descr
@@ -0,0 +1,17 @@
+spec.alpha
+
+spec is a Clojure library to describe the structure of data and functions.
+Specs can be used to validate data, conform (destructure) data, explain
+invalid data, generate examples that conform to the specs, and automatically
+use generative testing to test functions.
+
+Clojure 1.9 depends on this library and provides it to users of Clojure.
+Thus, the recommended way to use this library is to add a dependency on the
+latest version of Clojure 1.9, rather than including it directly. In some
+cases, this library may release more frequently than Clojure. In those cases,
+you can explictly include the latest version of this library with the
+dependency info below.
+
+For more information:
+
+WWW: https://clojure.org/about/spec