aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spidermonkey/Makefile
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-21 23:29:40 +0800
committersat <sat@FreeBSD.org>2006-05-21 23:29:40 +0800
commit7a3bdbf082fc7c3d71ba05ed440a76c5d417c6e6 (patch)
tree44279b4ccaf5b05e48268f84df64ccd130759650 /lang/spidermonkey/Makefile
parent649d9004a20bbf4102b3b83d27503dd0b126e59a (diff)
downloadfreebsd-ports-gnome-7a3bdbf082fc7c3d71ba05ed440a76c5d417c6e6.tar.gz
freebsd-ports-gnome-7a3bdbf082fc7c3d71ba05ed440a76c5d417c6e6.tar.zst
freebsd-ports-gnome-7a3bdbf082fc7c3d71ba05ed440a76c5d417c6e6.zip
- Expose jsstr.h
- Move plist to Makefile PR: ports/96549 Submitted by: sat Approved by: krion (mentor), maintainer
Diffstat (limited to 'lang/spidermonkey/Makefile')
-rw-r--r--lang/spidermonkey/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index b2954d44697d..320866b6d32b 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -53,6 +53,9 @@ ALL_TARGET= ${OPSYS}`${UNAME} -r`_DBG.OBJ/js
MAKE_ENV+= CC="${CC}" CCC="${CXX}"
INSTALLS_SHLIB= YES
SRC_DIR= js/src
+JSH= jsapi.h jsautocfg.h jscompat.h jslong.h jsosdep.h jsotypes.h jspubtd.h jstypes.h \
+ jsstr.h jshash.h jsprvtd.h
+PLIST_FILES= bin/js lib/libjs.so ${JSH:S,^,include/,}
WRKSRC= ${WRKDIR}/${SRC_DIR}
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
--exclude js/jsd \
@@ -84,8 +87,6 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/libjs.so \
${PREFIX}/lib
${CP} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/jsautocfg.h ${WRKSRC}
-.for jsh in jsapi.h jsautocfg.h jscompat.h jslong.h jsosdep.h jsotypes.h jspubtd.h jstypes.h
- @${INSTALL_DATA} ${WRKSRC}/${jsh} ${PREFIX}/include/
-.endfor
+ @${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} ${PREFIX}/include/
.include <bsd.port.post.mk>