aboutsummaryrefslogtreecommitdiffstats
path: root/lang/starlogo
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
committerlinimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
commitb52944915a792d1df1b4539b6ffef32bb06c623c (patch)
tree2d2342fe8b657b24efa68b7b0eedf07f0880f0b9 /lang/starlogo
parentcf6c4b2a7fb04e6bebe556711940aa746e81c384 (diff)
downloadfreebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.tar.gz
freebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.tar.zst
freebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.zip
Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,
remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp
Diffstat (limited to 'lang/starlogo')
-rw-r--r--lang/starlogo/Makefile2
-rw-r--r--lang/starlogo/files/starlogo.sh.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/starlogo/Makefile b/lang/starlogo/Makefile
index c893276821fe..8950c82582cb 100644
--- a/lang/starlogo/Makefile
+++ b/lang/starlogo/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= java@FreeBSD.org
COMMENT= Specialized version of the Logo programming language written in Java
USE_JAVA= yes
-JAVA_VERSION= 1.2+
+JAVA_VERSION= 1.5+
USE_ZIP= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/lang/starlogo/files/starlogo.sh.in b/lang/starlogo/files/starlogo.sh.in
index 344a6c123222..70248e4c8d3b 100644
--- a/lang/starlogo/files/starlogo.sh.in
+++ b/lang/starlogo/files/starlogo.sh.in
@@ -3,4 +3,4 @@
# $FreeBSD$
cd %%DATADIR%%/sample-projects && \
-JAVA_VERSION="1.2+" "%%LOCALBASE%%/bin/java" -cp "%%DATADIR%%/starlogo.jar" starlogo.Toplevel compiler english "init 100" "$@"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -cp "%%DATADIR%%/starlogo.jar" starlogo.Toplevel compiler english "init 100" "$@"