aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tcl82
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-09 17:49:14 +0800
committermiwi <miwi@FreeBSD.org>2007-03-09 17:49:14 +0800
commitdd4fdc45ceccef5684a6a703256927080b413881 (patch)
tree6c1207cc3ab36a9e126ce3e24c191293c88b325b /lang/tcl82
parentc70f4bbc6b537320650b8263cdb58e6fa5f9c054 (diff)
downloadfreebsd-ports-gnome-dd4fdc45ceccef5684a6a703256927080b413881.tar.gz
freebsd-ports-gnome-dd4fdc45ceccef5684a6a703256927080b413881.tar.zst
freebsd-ports-gnome-dd4fdc45ceccef5684a6a703256927080b413881.zip
- Adds TCL82_MAN and TCLSH_WRAPPER to OPTIONS
- Removes pseudo-installation of tclsh in favour of new lang/tcl-tk-wrapper port - Adds support for NO_INSTALL_MANPAGES knob - Pass maintainership to submitter - Bump PORTREVISION PR: 110088 Submitted by: Martin Matuska <martin@matuska.org>
Diffstat (limited to 'lang/tcl82')
-rw-r--r--lang/tcl82/Makefile15
-rw-r--r--lang/tcl82/pkg-deinstall.tclsh22
-rw-r--r--lang/tcl82/pkg-install.tclsh35
3 files changed, 11 insertions, 61 deletions
diff --git a/lang/tcl82/Makefile b/lang/tcl82/Makefile
index 34de77fe6013..c451662f3f63 100644
--- a/lang/tcl82/Makefile
+++ b/lang/tcl82/Makefile
@@ -7,13 +7,13 @@
PORTNAME= tcl
PORTVERSION= 8.2.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang tcl82
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= tcl8_2
DISTNAME= tcl8.2.3
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= martin@matuska.org
COMMENT= Tool Command Language
LATEST_LINK= tcl82
@@ -28,9 +28,16 @@ PKGDEINSTALL= ${PKGDIR}/pkg-deinstall.tclsh
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
PLIST_SUB= TCL_VER=8.2 SHORT_TCL_VER=82
+OPTIONS= TCL82_MAN "Install tcl 8.2 manpages" on \
+ TCLSH_WRAPPER "Require tclsh wrapper from ports" off
+
.include <bsd.port.pre.mk>
-.if defined(WITH_TCL82_MAN)
+.if defined(WITH_TCLSH_WRAPPER)
+RUN_DEPENDS+= tclsh:${PORTSDIR}/lang/tcl-tk-wrapper
+.endif
+
+.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TCL82_MAN)
MAN1= tclsh.1
@@ -384,7 +391,7 @@ post-configure:
${REINPLACE_CMD} \
-e 's|${WRKDIRPREFIX}${.CURDIR}|$${WRKDIRPREFIX}${TCLBASE}|' \
${WRKSRC}/tclConfig.sh
-.if !defined(WITH_TCL82_MAN)
+.if defined(NO_INSTALL_MANPAGES) || !defined(WITH_TCL82_MAN)
${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
${WRKSRC}/Makefile
.endif
diff --git a/lang/tcl82/pkg-deinstall.tclsh b/lang/tcl82/pkg-deinstall.tclsh
deleted file mode 100644
index c48dc863cf43..000000000000
--- a/lang/tcl82/pkg-deinstall.tclsh
+++ /dev/null
@@ -1,22 +0,0 @@
-#! /bin/sh
-#
-# Remove the ${PREFIX}/bin/tclsh script that gets installed by INSTALL.tclsh
-# if we are the last tclsh installation to be pkg_delete'd.
-#
-# $FreeBSD$
-#
-
-#
-# Explicitly listing /usr/X11R6/bin here is debatable.
-#
-BINDIR="${PKG_PREFIX}/bin /usr/X11R6/bin"
-TCLSH=${PKG_PREFIX}/bin/tclsh
-
-tclshs=$(/bin/ls ${BINDIR} 2> /dev/null | \
- egrep '^(i?tclsh[0-9]+\.[0-9]+(\_r)?([a-z][a-z])?)|otclsh$')
-
-if [ "$tclshs" = "" -a -f ${TCLSH} ] && \
- (head -3 ${TCLSH} | grep awieYJFnsuILOnfsYEW) > /dev/null 2>&1
-then
- rm -f ${PKG_PREFIX}/bin/tclsh
-fi
diff --git a/lang/tcl82/pkg-install.tclsh b/lang/tcl82/pkg-install.tclsh
deleted file mode 100644
index 3b808e2b500f..000000000000
--- a/lang/tcl82/pkg-install.tclsh
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-# The user may have a tclsh they want to preserve
-ver=`grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/tclsh 2> /dev/null \
- | sed -e 's/.*\*\*//'`
-if [ ! -e ${PKG_PREFIX}/bin/tclsh ] || [ "$ver" != "" -a "$ver" -lt 002 ]
-then
- [ -f ${PKG_PREFIX}/bin/tclsh ] && chmod u+w ${PKG_PREFIX}/bin/tclsh
-
- mkdir -p ${PKG_PREFIX}/bin
- cat > ${PKG_PREFIX}/bin/tclsh <<'EOF'
-#!/bin/sh
-# Installed by ports system. id: awieYJFnsuILOnfsYEW**002
-#
-# $FreeBSD$
-#
-
-(
-echo "In FreeBSD, tclsh is named with a version number. This is because"
-echo "different versions of tclsh are not compatible with each other and"
-echo "they can not all be called \"tclsh\"! You may need multiple versions"
-echo "installed because a given port may depend on a specific version."
-echo
-echo "On your system, tclsh is installed under at least the following names:"
-echo
-for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^(i?tclsh[0-9]+\.[0-9]+(\_r)?([a-z][a-z])?)|otclsh$')
-do
- echo $name
-done
-[ "$name" = "" ] && echo "No tclsh installations found, sorry."
-) 1>&2
-exit 1
-EOF
- chmod 555 ${PKG_PREFIX}/bin/tclsh
-fi