aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tolua++
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 23:28:28 +0800
commite836ab008ac38916a93472f2840e03e2e8470ef5 (patch)
tree1485083919fd5b153bf056ea17ac895ea758a8a9 /lang/tolua++
parent35d8b48dff5490ff5d7232109c287da637b58811 (diff)
downloadfreebsd-ports-gnome-e836ab008ac38916a93472f2840e03e2e8470ef5.tar.gz
freebsd-ports-gnome-e836ab008ac38916a93472f2840e03e2e8470ef5.tar.zst
freebsd-ports-gnome-e836ab008ac38916a93472f2840e03e2e8470ef5.zip
Replace lang/lua with the new lang/lua51
lang/lua51 is working the same way lang/lua52, chase ports using lua 5.1 Make the default lua lua52 Make all lua ports using USES=lua Approved by: portmgr (implicit)
Diffstat (limited to 'lang/tolua++')
-rw-r--r--lang/tolua++/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/tolua++/Makefile b/lang/tolua++/Makefile
index 55625d3e89a5..9d66083a3eea 100644
--- a/lang/tolua++/Makefile
+++ b/lang/tolua++/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= http://www.codenix.com/~tolua/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An extended version of tolua, a tool to integrate C/C++ code with Lua
-USES= tar:bzip2
-USE_LUA= 5.1
+USES= lua:51 tar:bzip2
USE_SCONS= yes
SCONS_ARGS= prefix=${PREFIX} SONAME="libtolua++-${LUA_VER}.so"
@@ -29,7 +28,7 @@ BROKEN= Does not install on sparc64-9
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|'lualib',||" ${WRKSRC}/config_posix.py
+ @${REINPLACE_CMD} -e "s|'lualib',||; s|lua|lua-${LUA_VER}|g" ${WRKSRC}/config_posix.py
do-install:
${MKDIR} ${STAGEDIR}${TGT_BINDIR} ${STAGEDIR}${TGT_INCDIR} ${STAGEDIR}${TGT_LIBDIR}