aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tolua50/files/patch-src::tests::Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-11-21 16:32:23 +0800
committeredwin <edwin@FreeBSD.org>2004-11-21 16:32:23 +0800
commit11d6e8ca1f7f24f1b6d750d5a4798bc14cf9db21 (patch)
treeb11083e3e98a97ee2564dfe2f5732fa37cad843e /lang/tolua50/files/patch-src::tests::Makefile
parent3d67e0c701263317f856be442330bafaa1e94a26 (diff)
downloadfreebsd-ports-gnome-11d6e8ca1f7f24f1b6d750d5a4798bc14cf9db21.tar.gz
freebsd-ports-gnome-11d6e8ca1f7f24f1b6d750d5a4798bc14cf9db21.tar.zst
freebsd-ports-gnome-11d6e8ca1f7f24f1b6d750d5a4798bc14cf9db21.zip
toLua is a tool that greatly simplifies the integration of C/C++
code with Lua. Based on a "cleaned" header file, toLua automatically generates the binding code to access C/C++ features from Lua. Using Lua-5.0 API and tag method facilities, the current version automatically maps C/C++ constants, external variables, functions, namespace, classes, and methods WWW: http://www.tecgraf.puc-rio.br/~celes/tolua/
Diffstat (limited to 'lang/tolua50/files/patch-src::tests::Makefile')
-rw-r--r--lang/tolua50/files/patch-src::tests::Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/lang/tolua50/files/patch-src::tests::Makefile b/lang/tolua50/files/patch-src::tests::Makefile
new file mode 100644
index 000000000000..a2aa53e7018d
--- /dev/null
+++ b/lang/tolua50/files/patch-src::tests::Makefile
@@ -0,0 +1,27 @@
+--- src/tests/Makefile.orig Wed Feb 11 23:01:58 2004
++++ src/tests/Makefile Sun Nov 21 19:17:49 2004
+@@ -4,7 +4,7 @@
+
+ include $(TOLUA)/config
+
+-LIBS = -ltolua -llua -llualib
++LIBS = -ltolua -llua -llualib -lm
+
+ all: tmodule tnamespace tclass tconstant tvariable tfunction tarray tdirective
+ ./tmodule; ./tnamespace; ./tclass; ./tconstant; ./tvariable; ./tfunction; ./tarray; ./tdirective;
+@@ -25,7 +25,7 @@
+ $(TOLUA)/bin/tolua -o $@ $<
+
+ tnamespace: tnamespace.o tnamespacebind.o
+- $(CC) $(CPPFLAGS) -o $@ tnamespace.o tnamespacebind.o $(TLIB) $(LIB) $(LIBS)
++ $(CC) $(CPPFLAGS) -Iedwin -o $@ tnamespace.o tnamespacebind.o $(TLIB) $(LIB) $(LIBS)
+ tnamespacebind.cpp: tnamespace.pkg
+ $(TOLUA)/bin/tolua -o $@ $<
+
+@@ -61,6 +61,3 @@
+
+ klean:
+ rm -f tmodule tnamespace tclass tconstant tvariable tfunction tarray tdirective
+-
+-
+-