aboutsummaryrefslogtreecommitdiffstats
path: root/lang/yap/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-07-29 11:30:21 +0800
committerijliao <ijliao@FreeBSD.org>2006-07-29 11:30:21 +0800
commitad6ce3931663e23a6d6ca81389793815e701be05 (patch)
treeb66390dcb63072fa42253c387b170505872210eb /lang/yap/Makefile
parent593ff373d0ae13ac9cbd4dcf1084c38eec3ea2fd (diff)
downloadfreebsd-ports-gnome-ad6ce3931663e23a6d6ca81389793815e701be05.tar.gz
freebsd-ports-gnome-ad6ce3931663e23a6d6ca81389793815e701be05.tar.zst
freebsd-ports-gnome-ad6ce3931663e23a6d6ca81389793815e701be05.zip
upgrade to 5.1.1
Diffstat (limited to 'lang/yap/Makefile')
-rw-r--r--lang/yap/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/lang/yap/Makefile b/lang/yap/Makefile
index 4d0023df765f..47303f2b561b 100644
--- a/lang/yap/Makefile
+++ b/lang/yap/Makefile
@@ -7,10 +7,10 @@
#
PORTNAME= yap
-PORTVERSION= 5.0.1
-PORTREVISION= 1
+PORTVERSION= 5.1.1
+PORTREVISION= 0
CATEGORIES= lang
-MASTER_SITES= http://www.ncc.up.pt/~vsc/Yap/%SUBDIR%/
+MASTER_SITES= http://www.ncc.up.pt/~vsc/Yap/current/
MASTER_SITE_SUBDIR= Yap-${PORTVERSION}
DISTNAME= Yap-${PORTVERSION}
@@ -23,6 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
INFO= yap
@@ -33,6 +34,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|VERSION}|VERSION:}|g' ${WRKSRC}/docs/yap.tex
+ @${REINPLACE_CMD} -e "s,make),${GMAKE})," \
+ -e "s,make install,${GMAKE} install," ${WRKSRC}/Makefile.in
post-build:
cd ${WRKSRC}/docs && makeinfo --no-split yap.tex
@@ -41,4 +44,10 @@ pre-install:
@${MKDIR} ${PREFIX}/${INFO_PATH}
${INSTALL_DATA} ${WRKSRC}/docs/yap.info ${PREFIX}/${INFO_PATH}
+post-install:
+ @${FIND} ${PREFIX}/share/Yap ! -type d | \
+ ${SED} "s,^${PREFIX},," >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/share/Yap -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX},@dirrm ," >> ${TMPPLIST}
+
.include <bsd.port.post.mk>
s='deletions'>-26/+28 * Convert my ports to optionsNGpawel2012-06-081-1/+3