aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-07-01 14:33:38 +0800
committerRene Ladan <rene@FreeBSD.org>2014-07-01 14:33:38 +0800
commit011f1923834306c13fbe8cdeef11058b09cd6617 (patch)
tree2f44bd9114e87eaedc94b1e66c8e3ce59cf8cc2a /lang
parent3abde05452b514fa881583e84d1b48e529f292e2 (diff)
downloadfreebsd-ports-gnome-011f1923834306c13fbe8cdeef11058b09cd6617.tar.gz
freebsd-ports-gnome-011f1923834306c13fbe8cdeef11058b09cd6617.tar.zst
freebsd-ports-gnome-011f1923834306c13fbe8cdeef11058b09cd6617.zip
Remove outdated ports:
2014-07-01 security/sudosh3: Funcition replaced by sudo -s 2014-07-01 security/sudosh: Funcition replaced by sudo -s 2014-07-01 security/sudosh2: Funcition replaced by sudo -s 2014-07-01 lang/pike76: Outdated: Users should switch to lang/pike78 2014-07-01 editors/gummi: Builds fine but the program itself is unusable
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/pike76/Makefile222
-rw-r--r--lang/pike76/distinfo2
-rw-r--r--lang/pike76/files/patch-Makefile11
-rw-r--r--lang/pike76/files/patch-ab13
-rw-r--r--lang/pike76/files/patch-install.pike11
-rw-r--r--lang/pike76/files/patch-src_modules_common_module_makefile.in20
-rw-r--r--lang/pike76/pkg-descr19
8 files changed, 0 insertions, 299 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 9da156e41824..eeca3dd30b05 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -243,7 +243,6 @@
SUBDIR += php55-extensions
SUBDIR += php_doc
SUBDIR += picoc
- SUBDIR += pike76
SUBDIR += pike78
SUBDIR += polyml
SUBDIR += ptoc
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
deleted file mode 100644
index 1d09af5389cb..000000000000
--- a/lang/pike76/Makefile
+++ /dev/null
@@ -1,222 +0,0 @@
-# Created by: kiwi@oav.net
-# $FreeBSD$
-
-PORTNAME= pike76
-PORTVERSION= 7.6.132
-PORTREVISION= 1
-CATEGORIES= lang
-MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
- http://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
- ftp://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
- http://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
- ftp://ftp.oav.net/pike/7.6/ \
- ftp://ftp.caudium.net/pike/official_releases/${PORTVERSION}/
-DISTNAME= Pike-v${PORTVERSION}
-
-MAINTAINER= johans@FreeBSD.org
-COMMENT= Dynamic programming language with a syntax similar to C++
-
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libtiff.so:${PORTSDIR}/graphics/tiff \
- libgdbm.so:${PORTSDIR}/databases/gdbm \
- libpcre.so:${PORTSDIR}/devel/pcre \
- libgmp.so:${PORTSDIR}/math/gmp
-
-DEPRECATED= Outdated: Users should switch to lang/pike78
-EXPIRATION_DATE=2014-07-01
-
-CONFLICTS= pike7[28]-[0-9]*
-CONFLICTS_BUILD=nettle-[2-9]*
-
-OPTIONS_DEFINE= TTF FREETYPE OPT_CFLAGS MYSQL FFMPEG PGSQL \
- SANE PDF SVG2 TDS FFTW ODBC
-OPTIONS_DEFAULT=TTF FREETYPE OPT_CFLAGS MYSQL
-
-TTF_DESC?= Add FreeType 1 support
-FREETYPE_DESC?= Add FreeType 2 support
-OPT_CFLAGS_DESC?= Enable additional compiliation optimizations
-FFMPEG_DESC?= Add FFmpeg support
-ODBC_DESC?= Add ODBC support
-SANE_DESC?= Add SANE support
-PDF_DESC?= Add PDF support
-SVG2_DESC?= Add SVG2 support
-TDS_DESC?= Add FreeTDS (Sybase and MSSQL) support
-FFTW_DESC?= Add libFFTW support
-
-MAN1= pike.1
-
-WANT_MESA= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-CONFIGURE_ARGS+=--without-debug \
- --with-thread-library=${PTHREAD_LIBS} \
- --with-double-precision \
- --with-long-double-precision \
- --disable-rpath \
- --without-rtldebug \
- --without-cdebug \
- --without-copt \
- --without-security \
- --with-oob \
- --without-poll \
- --without-devpoll \
- --with-max-fd=60000 \
- --with-gmp \
- --with-zlib \
- --with-threads \
- --with-readline \
- --with-jpeg \
- --with-tiff \
- --with-gdbm \
- --without-java \
- --without-ssleay \
- --without-GTK \
- --without-gnome \
- --without-glade \
- --without-libglade-config \
- --without-krb5 \
- --without-machine-code \
- --with-perl \
- --with-relocatable-dumped-modules \
- --without-GL --without-GLUT \
- --prefix=${PREFIX}
-
-MAKE_ARGS= CONFIGUREARGS="${CONFIGURE_ARGS}"
-MAKE_ENV= "ac_cv_lib_nettle_nettle_md5_init=no"
-
-USES= bison gettext gmake perl5
-
-PLIST_FILES= bin/pike bin/pike76 bin/hilfe
-
-NO_STAGE= yes
-MAKE_JOBS_UNSAFE=yes
-
-.include <bsd.port.pre.mk>
-
-ONLY_FOR_ARCHS= i386 amd64
-
-.if ${PORT_OPTIONS:MEXPERIMENTAL_FEATURES}
-CONFIGURE_ARGS+= --with-computed-goto \
- --with-pg \
- --with-long-long-int \
- --with-long-int \
- --with-short-int \
- --with-keypair-loop \
- --without-lock \
- --with-new-multisets
-.endif
-
-.if ${PORT_OPTIONS:MOPT_CFLAGS}
-.if (${MACHINE} == "i386")
-CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
-.else
-CFLAGS+= -ffast-math -fomit-frame-pointer
-.endif
-.endif
-
-.if ${PORT_OPTIONS:MFFMPEG}
-LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
-CONFIGURE_ARGS+= --with-ffmpeg
-.else
-CONFIGURE_ARGS+= --without-ffmpeg
-.endif
-
-.if ${PORT_OPTIONS:MFFTW}
-LIB_DEPENDS+= libfftw.so:${PORTSDIR}/math/fftw
-.endif
-
-.if ${PORT_OPTIONS:MTTF}
-LIB_DEPENDS+= libttf.so:${PORTSDIR}/print/freetype
-CONFIGURE_ARGS+= --with-ttflib
-.else
-CONFIGURE_ARGS+= --without-ttflib
-.endif
-
-.if ${PORT_OPTIONS:MFREETYPE}
-LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
-CONFIGURE_ARGS+= --with-freetype
-.else
-CONFIGURE_ARGS+= --without-freetype
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql=${PREFIX}
-.else
-CONFIGURE_ARGS+= --without-mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-CONFIGURE_ARGS+= --with-pgsql=${PREFIX}
-.else
-CONFIGURE_ARGS+= --without-pgsql
-.endif
-
-.if ${PORT_OPTIONS:MODBC}
-LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
-CONFIGURE_ARGS+= --with-odbc
-.else
-CONFIGURE_ARGS+= --without-odbc
-.endif
-
-.if ${PORT_OPTIONS:MSANE}
-LIB_DEPENDS+= libsane.so:${PORTSDIR}/graphics/sane-backends
-CONFIGURE_ARGS+= --with-sane
-.else
-CONFIGURE_ARGS+= --without-sane
-.endif
-
-.if ${PORT_OPTIONS:MPDF}
-LIB_DEPENDS+= libpdf.so:${PORTSDIR}/print/pdflib \
- libpanda.so:${PORTSDIR}/print/panda
-CONFIGURE_ARGS+= --with-libpdf --with-libpanda
-.else
-CONFIGURE_ARGS+= --without-libpdf --without-libpanda
-.endif
-
-.if ${PORT_OPTIONS:MSVG2}
-LIB_DEPENDS+= librsvg-2.so:${PORTSDIR}/graphics/librsvg2
-CONFIGURE_ARGS+= --with-svg
-.else
-CONFIGURE_ARGS+= --without-svg
-.endif
-
-.if ${PORT_OPTIONS:MTDS}
-LIB_DEPENDS+= libct.so:${PORTSDIR}/databases/freetds
-CONFIGURE_ARGS+= --with-sybase
-PLIST_SUB+= SYBASE:=""
-.else
-CONFIGURE_ARGS+= --without-sybase
-PLIST_SUB+= SYBASE:="@comment "
-.endif
-
-INSTALL_TARGET= install_nodoc
-
-pre-configure:
- @${ECHO} ${CONFIGURE_ARGS}
-
-post-patch:
- @${REINPLACE_CMD} -e 's| -lgmp| -L${LOCALBASE}/lib -lgmp|' \
- ${WRKSRC}/src/modules/Gmp/configure ${WRKSRC}/src/modules/_Image_XFace/configure
- @${REINPLACE_CMD} -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|' \
- -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
- -e "s|/cc/|&'|" \
- ${WRKSRC}/src/configure
-
-post-extract:
- @mv ${WRKSRC}/bundles/nettle-1.15.tar.gz \
- ${WRKSRC}/bundles/nettle-1.15.tar
- @gzip ${WRKSRC}/bundles/nettle-1.15.tar
-
-post-install:
- @${STRIP_CMD} ${PREFIX}/pike/${PORTVERSION}/bin/pike
- @${INSTALL_SCRIPT} ${WRKSRC}/bin/hilfe ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/man/pike.1 ${MAN1PREFIX}/man/man1
- @cd ${PREFIX} && ${FIND} pike/${PORTVERSION} ! -type d >> ${TMPPLIST}
- @cd ${PREFIX} && ${FIND} pike/${PORTVERSION} -type d -empty -delete
- @cd ${PREFIX} && ${FIND} -d pike/${PORTVERSION} -type d | \
- ${SED} 's,^,@dirrm ,' >> ${TMPPLIST}
- @${ECHO} '@unexec rmdir %D/pike 2>/dev/null || true' >> ${TMPPLIST}
-
-.include <bsd.port.post.mk>
diff --git a/lang/pike76/distinfo b/lang/pike76/distinfo
deleted file mode 100644
index 6027237244ce..000000000000
--- a/lang/pike76/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (Pike-v7.6.132.tar.gz) = aea7d70fb1d6845a5faff2d5d1c3b6f6fa6d5038d8dc08805c7b6e922198470f
-SIZE (Pike-v7.6.132.tar.gz) = 11759983
diff --git a/lang/pike76/files/patch-Makefile b/lang/pike76/files/patch-Makefile
deleted file mode 100644
index 4b0aae904738..000000000000
--- a/lang/pike76/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2007-04-18 21:19:27.000000000 +0400
-+++ Makefile 2011-09-15 15:14:33.000000000 +0400
-@@ -4,6 +4,8 @@
- # Meta Makefile
- #
-
-+unexport LDFLAGS
-+
- VPATH=.
- OS=`uname -s -r -m|sed \"s/ /-/g\"|tr \"[A-Z]\" \"[a-z]\"|tr \"/()\" \"___\"`
- BUILDDIR=build/$(OS)
diff --git a/lang/pike76/files/patch-ab b/lang/pike76/files/patch-ab
deleted file mode 100644
index 9b499b01c374..000000000000
--- a/lang/pike76/files/patch-ab
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/modules/_Image_FreeType/configure.orig 2007-04-15 14:40:08.000000000 +0200
-+++ src/modules/_Image_FreeType/configure 2011-03-11 10:35:16.000000000 +0100
-@@ -2688,8 +2688,8 @@ echo "${ECHO_T}no" >&6
- fi
-
- else
-- # Extract the first word of "${ac_tool_prefix}freetype-config", so it can be a program name with args.
--set dummy ${ac_tool_prefix}freetype-config; ac_word=$2
-+ # Extract the first word of "freetype-config", so it can be a program name with args.
-+set dummy freetype-config; ac_word=$2
- echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
- if test "${ac_cv_path_FT_CONFIG+set}" = set; then
diff --git a/lang/pike76/files/patch-install.pike b/lang/pike76/files/patch-install.pike
deleted file mode 100644
index 6b191124df74..000000000000
--- a/lang/pike76/files/patch-install.pike
+++ /dev/null
@@ -1,11 +0,0 @@
---- bin/install.pike.orig 2007-01-01 01:28:18.000000000 +0100
-+++ bin/install.pike 2011-03-11 10:35:16.000000000 +0100
-@@ -1707,7 +1707,7 @@ void do_install()
-
- if(file_stat(vars->MANDIR_SRC))
- {
-- install_dir(vars->MANDIR_SRC,combine_path(man_prefix,"man1"),0);
-+ //install_dir(vars->MANDIR_SRC,combine_path(man_prefix,"man1"),0);
- }
- };
-
diff --git a/lang/pike76/files/patch-src_modules_common_module_makefile.in b/lang/pike76/files/patch-src_modules_common_module_makefile.in
deleted file mode 100644
index 3be18eb332f7..000000000000
--- a/lang/pike76/files/patch-src_modules_common_module_makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/modules/common_module_makefile.in.orig 2011-03-12 19:54:33.000000000 +0100
-+++ src/modules/common_module_makefile.in 2011-03-12 19:54:35.000000000 +0100
-@@ -58,7 +58,7 @@ $(MODULE_ARCHIVES) ThisIsAPhonyTargetBla
- .c.o:
- @echo "Compiling $<" ;\
- rm -f $@.fail >/dev/null 2>&1; \
-- if $(CC) $(PREFLAGS) $(CFLAGS) -c $< -o $@ ; then : ; else \
-+ if $(CC) $(PREFLAGS) $(REAL_CPPFLAGS) $(CFLAGS) -c $< -o $@ ; then : ; else \
- status=$$?; \
- if test x"@noopt_retry@" = xyes ; then \
- echo "WARNING: Compiler failure! Trying without optimization!" >&2;\
-@@ -102,7 +102,7 @@ $(SRCDIR)/configure: $(SRCDIR)/configure
- cd $(SRCDIR) && $(PIKE_SRC_DIR)/run_autoconfig .
-
- config.status: $(SRCDIR)/configure
-- AR="$(AR)" CFLAGS="$(REAL_CFLAGS)" LDFLAGS="$(REAL_LDFLAGS)" LDSHARED="$(REAL_LDSHARED)" CPPFLAGS="$(REAL_CPPFLAGS)" BUILDDIR="$(TMP_BUILDDIR)" BINDIR="$(TMP_BINDIR)" PIKE_SRC_DIR="$(PIKE_SRC_DIR)" BUILD_BASE="$(BUILD_BASE)" ./config.status --recheck
-+ ./config.status --recheck AR="$(AR)" CFLAGS="$(REAL_CFLAGS)" LDFLAGS="$(REAL_LDFLAGS)" LDSHARED="$(REAL_LDSHARED)" CPPFLAGS="$(REAL_CPPFLAGS)" BUILDDIR="$(TMP_BUILDDIR)" BINDIR="$(TMP_BINDIR)" PIKE_SRC_DIR="$(PIKE_SRC_DIR)" BUILD_BASE="$(BUILD_BASE)"
-
- module.pmod: Makefile $(MODULE_PMOD_IN)
- @if [ "x$(MODULE_PMOD_IN)" != "x" ]; then \
diff --git a/lang/pike76/pkg-descr b/lang/pike76/pkg-descr
deleted file mode 100644
index 2445ce94ac6c..000000000000
--- a/lang/pike76/pkg-descr
+++ /dev/null
@@ -1,19 +0,0 @@
-Pike is an interpreted, object-oriented programming language.
-It looks a bit like C and C++, but it is much easier to learn and use. It
-can be used for small scripts as well as for large programs.
-
-Pike is :
-- High-level and powerful, which means that even very complex
- things are easy to do.
-- Object-oriented, which means that you can use modern programming
- techniques to divide a large program into small pieces, which are much
- easier to write than it would be to write the entire program at once.
-- Interpreted, which means that you don't have to wait for a program to
- compile and link when you want to run it.
-- One of the fastest "scripting" languages available.
-- Garbage-collected, which makes programming much simpler, and removes
- the risk for memory leaks and other memory-related bugs.
-- Easy to extend, which means that you can create plug-ins, written in
- Pike as well as in C or C++, and integrate them with the rest of Pike.
-
-WWW: http://pike.ida.liu.se/