aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2014-02-23 02:01:22 +0800
committergerald <gerald@FreeBSD.org>2014-02-23 02:01:22 +0800
commit0765279566f82e6878974825a183d35cab71870f (patch)
tree3697bbcecd3dcfca4852b4ddcf60aa710f2c50ff /lang
parente238d803eb8646190e37dde03068de10233ff5be (diff)
downloadfreebsd-ports-gnome-0765279566f82e6878974825a183d35cab71870f.tar.gz
freebsd-ports-gnome-0765279566f82e6878974825a183d35cab71870f.tar.zst
freebsd-ports-gnome-0765279566f82e6878974825a183d35cab71870f.zip
No longer add -I${LOCALBASE}/include to CFLAGS.
Since we now configure with --with-gmp=${LOCALBASE} this is no longer necessary, and due to bugs in binutils (which should not install ansidecl.h into ${PREFIX}/include, fixed with revision 336642 [1]) and GCC (which should search its own include directories with higher priority) could lead to build failures. Set the license to a combination of GPLv3 (for the compiler itself) and GPLv3 with GCC Runtime Library Exception (for the runtime). PR: 184327 [1]
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc46/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 8e5551a7654a..d5f5c4d85d63 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -13,6 +13,9 @@ DISTNAME= gcc-${DISTVERSION}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.6
+LICENSE= GPLv3 GPLv3RLE
+LICENSE_COMB= multi
+
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libmpfr.so:${PORTSDIR}/math/mpfr \
libmpc.so:${PORTSDIR}/math/mpc
@@ -61,7 +64,6 @@ WRKSRC= ${WRKDIR}/build
TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
.if empty(PORT_OPTIONS:MBOOTSTRAP)
CONFIGURE_ARGS+=--disable-bootstrap
.else