aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-12-15 00:06:19 +0800
committermat <mat@FreeBSD.org>2016-12-15 00:06:19 +0800
commit09fe311d63181518fddd8b7d771caad7c18fbfa7 (patch)
treedfb8fc1114d777545c03f25c7b98bb916a3a3d79 /lang
parenta2b877c4fac7ba53875259ed0c83c32dd5be45d7 (diff)
downloadfreebsd-ports-gnome-09fe311d63181518fddd8b7d771caad7c18fbfa7.tar.gz
freebsd-ports-gnome-09fe311d63181518fddd8b7d771caad7c18fbfa7.tar.zst
freebsd-ports-gnome-09fe311d63181518fddd8b7d771caad7c18fbfa7.zip
More USE_GITHUB cleanup.
Use GH_SUBDIR, or GH_TUPLE, where applicable. Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/rust-nightly/Makefile33
-rw-r--r--lang/swift/Makefile11
2 files changed, 10 insertions, 34 deletions
diff --git a/lang/rust-nightly/Makefile b/lang/rust-nightly/Makefile
index 348112fdac2f..2106d8decb80 100644
--- a/lang/rust-nightly/Makefile
+++ b/lang/rust-nightly/Makefile
@@ -16,19 +16,13 @@ DISTINFO_FILE= ${.CURDIR}/distinfo
PLIST= ${.CURDIR}/pkg-plist
USE_GITHUB= yes
-GH_ACCOUNT= rust-lang
-GH_PROJECT= rust \
- compiler-rt:compiler_rt \
- hoedown:hoedown \
- jemalloc:jemalloc \
- libc:liblibc \
- rust-installer:rust_installer
-GH_TAGNAME= 7ed6068 \
- ac3d1cd:compiler_rt \
- a3736a0:hoedown \
- e058ca6:jemalloc \
- b0d6253:liblibc \
- c37d374:rust_installer
+GH_TUPLE= rust-lang:rust:7ed6068 \
+ rust-lang:compiler-rt:ac3d1cd:compiler_rt/src/compiler-rt \
+ rust-lang:hoedown:a3736a0:hoedown/src/rt/hoedown \
+ rust-lang:jemalloc:e058ca6:jemalloc/src/jemalloc \
+ rust-lang:libc:b0d6253:liblibc/src/liblibc \
+ rust-lang:rust-installer:c37d374:rust_installer/src/rust-installer \
+ rust-lang:llvm:7ca76af:llvm
BUILD_DEPENDS= cmake:devel/cmake
@@ -42,19 +36,6 @@ PORT_LLVM_GH_PROJECT_OFF= llvm:llvm
PORT_LLVM_GH_TAGNAME_OFF= 7ca76af:llvm
PORT_LLVM_VARS_OFF= NOPRECIOUSMAKEVARS=1 # ARCH
-post-extract: slave-post-extract
-slave-post-extract:
- @(${RMDIR} ${WRKSRC}/src/compiler-rt && \
- ${MV} ${WRKSRC_compiler_rt} ${WRKSRC}/src/compiler-rt)
- @(${RMDIR} ${WRKSRC}/src/rt/hoedown && \
- ${MV} ${WRKSRC_hoedown} ${WRKSRC}/src/rt/hoedown)
- @(${RMDIR} ${WRKSRC}/src/jemalloc && \
- ${MV} ${WRKSRC_jemalloc} ${WRKSRC}/src/jemalloc)
- @(${RMDIR} ${WRKSRC}/src/liblibc && \
- ${MV} ${WRKSRC_liblibc} ${WRKSRC}/src/liblibc)
- @(${RMDIR} ${WRKSRC}/src/rust-installer && \
- ${MV} ${WRKSRC_rust_installer} ${WRKSRC}/src/rust-installer)
-
post-extract-PORT_LLVM-off:
@(${RMDIR} ${WRKSRC}/src/llvm && \
${MV} ${WRKSRC_llvm} ${WRKSRC}/src/llvm)
diff --git a/lang/swift/Makefile b/lang/swift/Makefile
index 881bbdc2c7cf..398a4a1174fb 100644
--- a/lang/swift/Makefile
+++ b/lang/swift/Makefile
@@ -27,6 +27,9 @@ GH_PROJECT= swift:DEFAULT swift-llvm:llvm swift-clang:clang swift-lldb:lldb \
swift-corelibs-xctest:xctest swift-corelibs-foundation:xcfound
GH_TAGNAME= swift-${PORTVERSION}-RELEASE:DEFAULT,llvm,clang,lldb,cmark \
swift-DEVELOPMENT-SNAPSHOT-2016-05-03-a:llbuild,swiftpm,xctest,xcfound
+GH_SUBDIR= llvm:llvm clang:clang lldb:lldb cmark:cmark llbuild:llbuild \
+ swiftpm:swiftpm swift-corelibs-xctest:xctest \
+ swift-corelibs-foundation:xcfound
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= iconv libedit ninja perl5 pkgconfig python:3,build sqlite
@@ -55,14 +58,6 @@ BROKEN= Does not build
post-extract:
@${MKDIR} ${WRKSRC}
@${MV} ${WRKDIR}/${PORTNAME}-${PORTNAME}-${PORTVERSION}-RELEASE ${WRKSRC}/swift
- @${MV} ${WRKSRC_llvm} ${WRKSRC}/llvm
- @${MV} ${WRKSRC_clang} ${WRKSRC}/clang
- @${MV} ${WRKSRC_lldb} ${WRKSRC}/lldb
- @${MV} ${WRKSRC_cmark} ${WRKSRC}/cmark
- @${MV} ${WRKSRC_llbuild} ${WRKSRC}/llbuild
- @${MV} ${WRKSRC_swiftpm} ${WRKSRC}/swiftpm
- @${MV} ${WRKSRC_xctest} ${WRKSRC}/swift-corelibs-xctest
- @${MV} ${WRKSRC_xcfound} ${WRKSRC}/swift-corelibs-foundation
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \