aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-05-13 08:23:02 +0800
committergerald <gerald@FreeBSD.org>2013-05-13 08:23:02 +0800
commit0d932d5556005e2073eb6607ae042e8e9e6ca6eb (patch)
tree71446c8374427bce20fe1a8c383dc21c32feb563 /lang
parent93c12318615736b235665e589a3de559f1356323 (diff)
downloadfreebsd-ports-gnome-0d932d5556005e2073eb6607ae042e8e9e6ca6eb.tar.gz
freebsd-ports-gnome-0d932d5556005e2073eb6607ae042e8e9e6ca6eb.tar.zst
freebsd-ports-gnome-0d932d5556005e2073eb6607ae042e8e9e6ca6eb.zip
Update to GCC 4.6.4, the final release and end of the GCC 4.6 branch.
(This requires an EPOCH bump due to how snapshots are labeled.) Introduce a new option BOOTSTRAP that allows for doing a full bootstrap of GCC, as opposed to just running a simple build. Bootstrapping is actually the default upstream, we disable it by default for the stable flavors of GCC since that is a huge win in terms of build time of the port. No change in default behavior for this port.
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc46/Makefile21
-rw-r--r--lang/gcc46/distinfo4
2 files changed, 15 insertions, 10 deletions
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index c378435eeea2..79f7a3a8685e 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 4.6.4.20130215
+PORTVERSION= 4.6.4
+PORTEPOCH= 1
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
-MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
-DISTNAME= gcc-${VERSIONSTRING}
+MASTER_SITE_SUBDIR= releases/gcc-${VERSIONSTRING}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.6
@@ -25,7 +25,7 @@ CONFLICTS= gcc-4.6.[123]*
# VERSIONSTRING relates to downloads, GCC_VERSION and SUFFIX to names
# of executables and directories once installed.
-VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
+VERSIONSTRING= ${PORTVERSION}
GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
@@ -40,10 +40,12 @@ MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
+OPTIONS_DEFINE= BOOTSTRAP
OPTIONS_DEFINE_i386= JAVA
OPTIONS_DEFINE_amd64= JAVA
OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
+BOOTSTRAP_DESC= Build using a full bootstrap
.include <bsd.port.pre.mk>
@@ -60,8 +62,10 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+=--disable-bootstrap \
- --disable-nls \
+.if empty(PORT_OPTIONS:MBOOTSTRAP)
+CONFIGURE_ARGS+=--disable-bootstrap
+.endif
+CONFIGURE_ARGS+=--disable-nls \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
--program-suffix=${SUFFIX} \
@@ -89,9 +93,10 @@ INFO= gcc${SUFFIX}/cpp \
gcc${SUFFIX}/gccint \
gcc${SUFFIX}/gfortran \
gcc${SUFFIX}/libgomp
-.if ${ARCH} != "ia64" && ${ARCH} != "powerpc" && ${ARCH} != "sparc64"
+# Release tarballs (as opposed to snapshots) always carry this.
+#.if ${ARCH} != "ia64" && ${ARCH} != "powerpc" && ${ARCH} != "sparc64"
INFO+= gcc${SUFFIX}/libquadmath
-.endif
+#.endif
.if ${PORT_OPTIONS:MJAVA}
ECJ_JAR= ${LOCALBASE}/share/java/ecj-4.5.jar
diff --git a/lang/gcc46/distinfo b/lang/gcc46/distinfo
index 0e2721d98313..9214124401ed 100644
--- a/lang/gcc46/distinfo
+++ b/lang/gcc46/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.6-20130215.tar.bz2) = ba09fa687b5f55527952c11b588de359868a9257b7bf4271d1d575a441fd2f1a
-SIZE (gcc-4.6-20130215.tar.bz2) = 68134979
+SHA256 (gcc-4.6.4.tar.bz2) = 35af16afa0b67af9b8eb15cafb76d2bc5f568540552522f5dc2c88dd45d977e8
+SIZE (gcc-4.6.4.tar.bz2) = 72006076