aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-05 23:05:29 +0800
committeraz <az@FreeBSD.org>2013-08-05 23:05:29 +0800
commit12549b30c2eef8132a2851d6f17e8c45a3491872 (patch)
tree6094da914716107bca7d35889c1b8aab5e6097c7 /lang
parent7e71988ad884bca5467171d41d1f68fd7040697b (diff)
downloadfreebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.tar.gz
freebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.tar.zst
freebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.zip
- Convert to new perl framework
- Trim Makefile header Approved by: tobez@ (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-Data-JavaScript/Makefile9
-rw-r--r--lang/p5-Perl6-Subs/Makefile9
-rw-r--r--lang/p5-Scalar-List-Utils/Makefile3
-rw-r--r--lang/p5-Switch/Makefile9
-rw-r--r--lang/p5-Try-Tiny/Makefile3
-rw-r--r--lang/p5-signatures/Makefile3
6 files changed, 15 insertions, 21 deletions
diff --git a/lang/p5-Data-JavaScript/Makefile b/lang/p5-Data-JavaScript/Makefile
index 1ecc8a0b07b6..6962a1f3a46c 100644
--- a/lang/p5-Data-JavaScript/Makefile
+++ b/lang/p5-Data-JavaScript/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-JavaScript
-# Date created: 09 October 2001
-# Whom: tobez
-#
+# Created by: tobez
# $FreeBSD$
-#
PORTNAME= Data-JavaScript
PORTVERSION= 1.13
@@ -16,7 +12,8 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= Data::JavaScript - Dump perl structures to JavaScript code
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::JavaScript.3
diff --git a/lang/p5-Perl6-Subs/Makefile b/lang/p5-Perl6-Subs/Makefile
index 9c9db50499b9..0372e019886f 100644
--- a/lang/p5-Perl6-Subs/Makefile
+++ b/lang/p5-Perl6-Subs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lang/p5-Perl6-Subs
-# Date created: 07 January 2006
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Perl6-Subs
PORTVERSION= 0.05
@@ -18,7 +14,8 @@ COMMENT= Perl6::Subs - Define your subroutines in the Perl 6 style
BUILD_DEPENDS= p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Perl6::Subs.3
diff --git a/lang/p5-Scalar-List-Utils/Makefile b/lang/p5-Scalar-List-Utils/Makefile
index 3a35732865ef..d3b51598ff08 100644
--- a/lang/p5-Scalar-List-Utils/Makefile
+++ b/lang/p5-Scalar-List-Utils/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl subroutines that would be nice to have in the perl core
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= List::Util.3 Scalar::Util.3 List::Util::XS.3
diff --git a/lang/p5-Switch/Makefile b/lang/p5-Switch/Makefile
index 3c53f619e8fc..286697063ac4 100644
--- a/lang/p5-Switch/Makefile
+++ b/lang/p5-Switch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lang/p5-Switch
-# Date created: 26 April 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= Switch
PORTVERSION= 2.16
@@ -18,7 +14,8 @@ COMMENT= Switch - A switch statement for Perl
BUILD_DEPENDS= p5-Filter>0:${PORTSDIR}/devel/p5-Filter
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Switch.3
diff --git a/lang/p5-Try-Tiny/Makefile b/lang/p5-Try-Tiny/Makefile
index 7031c445434e..fd6ae1522dab 100644
--- a/lang/p5-Try-Tiny/Makefile
+++ b/lang/p5-Try-Tiny/Makefile
@@ -11,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Minimal try/catch with proper localization of $$@
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Try::Tiny.3
diff --git a/lang/p5-signatures/Makefile b/lang/p5-signatures/Makefile
index 793e20cd3e9a..01c6a07046b1 100644
--- a/lang/p5-signatures/Makefile
+++ b/lang/p5-signatures/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= signatures.3