aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-12-18 12:47:15 +0800
committergerald <gerald@FreeBSD.org>2012-12-18 12:47:15 +0800
commit12d4114f058c4436f2ed075fa9f9873f645e9fb5 (patch)
tree8fa576c017aa26c51c67153b13f8e35741912d80 /lang
parent1cef65c958d7d9fde5d2c966edc3feb0382f6881 (diff)
downloadfreebsd-ports-gnome-12d4114f058c4436f2ed075fa9f9873f645e9fb5.tar.gz
freebsd-ports-gnome-12d4114f058c4436f2ed075fa9f9873f645e9fb5.tar.zst
freebsd-ports-gnome-12d4114f058c4436f2ed075fa9f9873f645e9fb5.zip
Reintroduce, adjusted to current upstream changes, my hack to get
to the unwinder interface to get FreeBSD/ia64 build. [1] Update to the 20121216 snapshot of GCC 4.8.0. Submitted by: Anton Shterenlikht <mexas@bristol.ac.uk> [1]
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc48/Makefile2
-rw-r--r--lang/gcc48/distinfo4
-rw-r--r--lang/gcc48/files/patch-unwind-ia64.h20
3 files changed, 23 insertions, 3 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 3dec97145cb2..e5aa92032b06 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 4.8.0.20121209
+PORTVERSION= 4.8.0.20121216
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
diff --git a/lang/gcc48/distinfo b/lang/gcc48/distinfo
index 26fd0104df01..9f139d3dcbef 100644
--- a/lang/gcc48/distinfo
+++ b/lang/gcc48/distinfo
@@ -1,4 +1,4 @@
-SHA256 (gcc-4.8-20121209.tar.bz2) = a76e783d11cc879be10af56e6b4219b373eee1c8b0cd651573830ae2f814e24a
-SIZE (gcc-4.8-20121209.tar.bz2) = 81893352
+SHA256 (gcc-4.8-20121216.tar.bz2) = f813e9aa9da33dca76c4bef52fe4cdc5edccffeed2ffaceaaa7efb1938afb22c
+SIZE (gcc-4.8-20121216.tar.bz2) = 81933875
SHA256 (ecj-4.5.jar) = 98fd128f1d374d9e42fd9d4836bdd249c6d511ebc6c0df17fbc1b9df96c3d781
SIZE (ecj-4.5.jar) = 1470676
diff --git a/lang/gcc48/files/patch-unwind-ia64.h b/lang/gcc48/files/patch-unwind-ia64.h
new file mode 100644
index 000000000000..57f97172e207
--- /dev/null
+++ b/lang/gcc48/files/patch-unwind-ia64.h
@@ -0,0 +1,20 @@
+2012-12-17 Gerald Pfeifer <gerald@pfeifer.com>
+ Anton Shterenlikht <mexas@bristol.ac.uk>
+
+ PR target/45650
+ * config/ia64/unwind-ia64.h: Do not mark _Unwind_FindTableEntry
+ hidden on FreeBSD.
+
+Index: libgcc/config/ia64/unwind-ia64.h
+===================================================================
+--- libgcc/config/ia64/unwind-ia64.h
++++ libgcc/config/ia64/unwind-ia64.h (working copy)
+@@ -49,4 +49,7 @@
+ extern struct unw_table_entry *
+ _Unwind_FindTableEntry (void *pc, unw_word *segment_base,
+ unw_word *gp, struct unw_table_entry *ent)
+- __attribute__ ((__visibility__ ("hidden")));
++#ifndef __FreeBSD__
++ __attribute__ ((__visibility__ ("hidden")))
++#endif
++ ;