aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2012-10-24 05:14:20 +0800
committerRene Ladan <rene@FreeBSD.org>2012-10-24 05:14:20 +0800
commit1835c1b289426d88c5937cdc391bbae259fe692f (patch)
tree590a2f35cea96c894c8c3d7701bce3a3027e54e9 /lang
parent03053661acccdede76025424ae0b5a48a6ca71ce (diff)
downloadfreebsd-ports-gnome-1835c1b289426d88c5937cdc391bbae259fe692f.tar.gz
freebsd-ports-gnome-1835c1b289426d88c5937cdc391bbae259fe692f.tar.zst
freebsd-ports-gnome-1835c1b289426d88c5937cdc391bbae259fe692f.zip
Use optionsNG syntax for NOPORTDOCS
Feature safe: yes
Diffstat (limited to 'lang')
-rw-r--r--lang/bas2tap/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/bas2tap/Makefile b/lang/bas2tap/Makefile
index f18d639fa91b..87f34393f55d 100644
--- a/lang/bas2tap/Makefile
+++ b/lang/bas2tap/Makefile
@@ -18,12 +18,14 @@ NO_WRKSUBDIR= yes
PORTDOCS= ${PORTNAME}.doc
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.options.mk>
+
do-build:
${CC} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME} -lm ${CFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}