aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-11-10 18:09:48 +0800
committermat <mat@FreeBSD.org>2018-11-10 18:09:48 +0800
commit1b0417656969bd1c326432fe019d9a6f6bf42997 (patch)
treeec00e643384652d97e7643f40c6342bff01bff0b /lang
parente5874ca09869a82a5afd977e105a07506a5f15ad (diff)
downloadfreebsd-ports-gnome-1b0417656969bd1c326432fe019d9a6f6bf42997.tar.gz
freebsd-ports-gnome-1b0417656969bd1c326432fe019d9a6f6bf42997.tar.zst
freebsd-ports-gnome-1b0417656969bd1c326432fe019d9a6f6bf42997.zip
security/openssl-devel was removed, but there is a security/openssl111 now.
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime15/Makefile2
-rw-r--r--lang/erlang-runtime16/Makefile2
-rw-r--r--lang/erlang-runtime17/Makefile2
-rw-r--r--lang/erlang-runtime18/Makefile2
-rw-r--r--lang/erlang-runtime19/Makefile2
-rw-r--r--lang/erlang-runtime20/Makefile2
-rw-r--r--lang/erlang-runtime21/Makefile2
-rw-r--r--lang/phantomjs/Makefile4
-rw-r--r--lang/php56/Makefile.ext4
-rw-r--r--lang/python34/Makefile2
-rw-r--r--lang/ruby23/Makefile4
11 files changed, 14 insertions, 14 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index d71404f4d7f7..c89d81feb3dd 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -45,7 +45,7 @@ OPTIONS_EXCLUDE+= DTRACE
OPTIONS_EXCLUDE_DragonFly= HIPE SCTP
-OPENSSL_VARS= BROKEN_SSL=openssl-devel openssl111
+OPENSSL_VARS= BROKEN_SSL=openssl111
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index 449a79e62c15..56fd3e990630 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -45,7 +45,7 @@ OPTIONS_EXCLUDE+= DTRACE
OPTIONS_EXCLUDE_DragonFly= HIPE SCTP
-OPENSSL_VARS= BROKEN_SSL=openssl-devel openssl111
+OPENSSL_VARS= BROKEN_SSL=openssl111
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 8f21a9e8e2cc..76d32085b397 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -64,7 +64,7 @@ OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
-OPENSSL_VARS= BROKEN_SSL=openssl-devel openssl111
+OPENSSL_VARS= BROKEN_SSL=openssl111
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime18/Makefile b/lang/erlang-runtime18/Makefile
index 548b9896bf34..2a3a5f83501e 100644
--- a/lang/erlang-runtime18/Makefile
+++ b/lang/erlang-runtime18/Makefile
@@ -65,7 +65,7 @@ OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
-OPENSSL_VARS= BROKEN_SSL=openssl-devel openssl111
+OPENSSL_VARS= BROKEN_SSL=openssl111
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime19/Makefile b/lang/erlang-runtime19/Makefile
index 97195c06af99..871663fad053 100644
--- a/lang/erlang-runtime19/Makefile
+++ b/lang/erlang-runtime19/Makefile
@@ -69,7 +69,7 @@ OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
-OPENSSL_VARS= BROKEN_SSL=openssl-devel
+OPENSSL_VARS= BROKEN_SSL=openssl111
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime20/Makefile b/lang/erlang-runtime20/Makefile
index 17198bf013b2..eb740ab959ff 100644
--- a/lang/erlang-runtime20/Makefile
+++ b/lang/erlang-runtime20/Makefile
@@ -72,7 +72,7 @@ OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
-OPENSSL_VARS= BROKEN_SSL=openssl-devel
+OPENSSL_VARS= BROKEN_SSL=openssl111
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/erlang-runtime21/Makefile b/lang/erlang-runtime21/Makefile
index dc4610028e67..6ca3774c77d4 100644
--- a/lang/erlang-runtime21/Makefile
+++ b/lang/erlang-runtime21/Makefile
@@ -66,7 +66,7 @@ OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
-OPENSSL_VARS= BROKEN_SSL=openssl-devel
+OPENSSL_VARS= BROKEN_SSL=openssl111
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index b13c41d2cb24..6befd6326e24 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -12,8 +12,8 @@ LICENSE= BSD3CLAUSE
BROKEN_powerpc64= fails to build: g++48: not found
BROKEN_sparc64= does not link on sparc64
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= error: member access into incomplete type 'X509' (aka 'x509_st')
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= error: member access into incomplete type 'X509' (aka 'x509_st')
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libfreetype.so:print/freetype2 \
diff --git a/lang/php56/Makefile.ext b/lang/php56/Makefile.ext
index 14ea40a5a5f1..fcd276191a21 100644
--- a/lang/php56/Makefile.ext
+++ b/lang/php56/Makefile.ext
@@ -527,8 +527,8 @@ USES+= mysql
.include <bsd.port.pre.mk>
-.if ${PHP_MODNAME} == "openssl" && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
+.if ${PHP_MODNAME} == "openssl" && ${SSL_DEFAULT:Mopenssl111}
+BROKEN= Does not build with openssl111
.endif
.if ${PHP_MODNAME} == "gd"
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 02fb48cdea55..765e81a4760b 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -15,7 +15,7 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-BROKEN_SSL= openssl-devel
+BROKEN_SSL= openssl111
USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
diff --git a/lang/ruby23/Makefile b/lang/ruby23/Makefile
index e3cfded2f93d..cddc14eefa2b 100644
--- a/lang/ruby23/Makefile
+++ b/lang/ruby23/Makefile
@@ -18,8 +18,8 @@ LICENSE_COMB= dual
LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel=does not detect and buid the openssl*.rb bits
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111=does not detect and buid the openssl*.rb bits
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
BUILD_DEPENDS= libffi>=0:devel/libffi