aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
commit1ca518c98321627ea34bdaae84c439a2f0df0cdf (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /lang
parent81215f7fb03620d52b441a5714e6af1fb655c743 (diff)
downloadfreebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.gz
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.zst
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Diffstat (limited to 'lang')
-rw-r--r--lang/fpc/Makefile.units2
-rw-r--r--lang/icc/Makefile9
-rw-r--r--lang/ifc/Makefile3
-rw-r--r--lang/php5/Makefile.ext2
-rw-r--r--lang/php53/Makefile.ext2
-rw-r--r--lang/spidermonkey17/Makefile3
6 files changed, 7 insertions, 14 deletions
diff --git a/lang/fpc/Makefile.units b/lang/fpc/Makefile.units
index 3d83adcbf317..9548ed918dd6 100644
--- a/lang/fpc/Makefile.units
+++ b/lang/fpc/Makefile.units
@@ -14,7 +14,7 @@ UNITEXTRACT_SUFX= .tar.gz
UNITNAME= ${UNITPREFIX}${PKGNAMESUFFIX:S/-//}${BUILDNAME:S/^/./}${UNITEXTRACT_SUFX}
UNITDIR= lib/fpc/${PORTVERSION}/units/${BUILDNAME}
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXTRACTUNITDIR}
+EXTRACT_AFTER_ARGS= ${EXTRACTUNITDIR}
OPT=-Ur -CX
MAKE_ENV+= PP=${LOCALBASE}/bin/${PPNAME} \
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 84b398778fc1..a748b54a3efb 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: icc
-# Date created: 24.Jan.2002
-# Whom: netchild@FreeBSD.org
-#
+# Created by: netchild@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= icc
PORTVERSION= 8.1.038
@@ -45,8 +41,7 @@ ICC_SITE= http://www.intel.com/software/products/compilers/
.include <bsd.port.pre.mk>
-EXTRACT_AFTER_ARGS= | tar -xf - \
- --exclude cdt-\*.zip \
+EXTRACT_AFTER_ARGS= --exclude cdt-\*.zip \
--exclude eclipse-platform\*.zip \
--exclude intel-icc_ide\*.rpm \
--exclude intel-iidb\*.rpm \
diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index bc520a50a02b..7f646ef93da8 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -37,8 +37,7 @@ IFC_SITE= http://www.intel.com/software/products/compilers/
.include <bsd.port.pre.mk>
-EXTRACT_AFTER_ARGS= | tar -xf - \
- --exclude intel-iidb\*.rpm \
+EXTRACT_AFTER_ARGS= --exclude intel-iidb\*.rpm \
--exclude \*ia64.rpm \
--exclude chklic.64 \
--exclude flexlm64
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 24cb5a06dfa8..1d6414dd0d89 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -11,7 +11,7 @@ WRKSRC= ${WRKDIR}/${EXTSUBDIR}
PATCHDIR= ${.CURDIR}/files
PLIST= ${NONEXISTENT}
-EXTRACT_AFTER_ARGS?= | ${TAR} -xf - ${EXTSUBDIR}
+EXTRACT_AFTER_ARGS?= ${EXTSUBDIR}
.if ${PHP_MODNAME} == "bcmath"
CONFIGURE_ARGS+=--enable-bcmath
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 506597091cbe..3f07c9719047 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -11,7 +11,7 @@ WRKSRC= ${WRKDIR}/${EXTSUBDIR}
PATCHDIR= ${.CURDIR}/files
PLIST= ${NONEXISTENT}
-EXTRACT_AFTER_ARGS?= | ${TAR} -xf - ${EXTSUBDIR}
+EXTRACT_AFTER_ARGS?= ${EXTSUBDIR}
.if ${PHP_MODNAME} == "bcmath"
CONFIGURE_ARGS+=--enable-bcmath
diff --git a/lang/spidermonkey17/Makefile b/lang/spidermonkey17/Makefile
index 23d0c5ed78d9..84ba0948cb25 100644
--- a/lang/spidermonkey17/Makefile
+++ b/lang/spidermonkey17/Makefile
@@ -42,8 +42,7 @@ JSH= jsapi.h jsarena.h jsarray.h jsatom.h jsautocfg.h jsbool.h \
PLIST_FILES= bin/js lib/libjs.so lib/libjs.so.1 ${JSH:S,^,include/,}
WRKSRC= ${WRKDIR}/${SRC_DIR}
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
- --exclude js/jsd
+EXTRACT_AFTER_ARGS= --exclude js/jsd
OPTIONS= UTF8 "Enable UTF8 support" Off