aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-08 02:34:07 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-08 02:34:07 +0800
commit20d7c439c89cfb1fd40c3bbb5acee4391061a7f4 (patch)
treed77b98d157dd1c66caa826d00a75a8d28b5348aa /lang
parentacdac520ff4ea85759b33e3903f052541cdcccbc (diff)
downloadfreebsd-ports-gnome-20d7c439c89cfb1fd40c3bbb5acee4391061a7f4.tar.gz
freebsd-ports-gnome-20d7c439c89cfb1fd40c3bbb5acee4391061a7f4.tar.zst
freebsd-ports-gnome-20d7c439c89cfb1fd40c3bbb5acee4391061a7f4.zip
PERL -> REINPLACE_CMD
PR: 40289 Submitted by: maintainer
Diffstat (limited to 'lang')
-rw-r--r--lang/njs/Makefile10
-rw-r--r--lang/njs/files/patch-configure11
2 files changed, 16 insertions, 5 deletions
diff --git a/lang/njs/Makefile b/lang/njs/Makefile
index 24ee902d63c9..e5f5083cc18d 100644
--- a/lang/njs/Makefile
+++ b/lang/njs/Makefile
@@ -18,16 +18,16 @@ MAINTAINER= thierry@pompo.net
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
+.if defined(NOPORTDOCS)
+USE_REINPLACE= yes
+.endif
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared
MAN1= js.1 jsdas.1
post-extract:
- ${RM} ${WRKSRC}/docs/js.info*
-
-post-patch:
- ${PERL} -pi -e 's:=makeinfo:="makeinfo --no-split":g' ${WRKSRC}/configure
+ @${RM} ${WRKSRC}/docs/js.info*
pre-configure:
@if [ -f ${LOCALBASE}/include/js.h ]; then \
@@ -39,7 +39,7 @@ pre-configure:
pre-install:
.if defined(NOPORTDOCS)
- ${PERL} -pi -e "s:docs micros examples:micros:g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s:docs micros examples:micros:g" ${WRKSRC}/Makefile
.endif
post-install:
diff --git a/lang/njs/files/patch-configure b/lang/njs/files/patch-configure
new file mode 100644
index 000000000000..26e3d8b7f2df
--- /dev/null
+++ b/lang/njs/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jan 15 08:39:56 1999
++++ configure Sun Jul 7 14:04:03 2002
+@@ -791,7 +791,7 @@
+ # an executable is not found, even if stderr is redirected.
+ # Redirect stdin to placate older versions of autoconf. Sigh.
+ if (makeinfo --version) < /dev/null > /dev/null 2>&1; then
+- MAKEINFO=makeinfo
++ MAKEINFO="makeinfo --no-split"
+ echo "$ac_t""found" 1>&6
+ else
+ MAKEINFO="$missing_dir/missing makeinfo"