aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2003-08-15 08:49:31 +0800
committerkuriyama <kuriyama@FreeBSD.org>2003-08-15 08:49:31 +0800
commit23487909ca7033a70fc30adfb2f3bdadddcee493 (patch)
treec7a9a132ab286601d6d7a3590fd42cad88671385 /lang
parent39602a96bc814acbf78e72edd603b5471a42823c (diff)
downloadfreebsd-ports-gnome-23487909ca7033a70fc30adfb2f3bdadddcee493.tar.gz
freebsd-ports-gnome-23487909ca7033a70fc30adfb2f3bdadddcee493.tar.zst
freebsd-ports-gnome-23487909ca7033a70fc30adfb2f3bdadddcee493.zip
Fix non-default dependency on openldap2[012] which is broken by splitting.
# I'm not bumped port revision of them because this should not affect # packages built on bento...
Diffstat (limited to 'lang')
-rw-r--r--lang/php4/Makefile6
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php53/Makefile2
3 files changed, 5 insertions, 5 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index e907ce48f1f4..9959dca7a3c9 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -437,12 +437,12 @@ CONFIGURE_ARGS+=--with-ncurses=${NCURSESBASE}
LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
.elif exists(${LOCALBASE}/lib/libldap.la)
.if exists(${LOCALBASE}/bin/ldapwhoami)
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21-client
.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20-client
.endif
.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap22
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap22-client
.endif
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
.endif
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 9dd2b76acffa..e2b3ee2aad2d 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -424,7 +424,7 @@ CONFIGURE_ARGS+=--with-ncurses=${NCURSESBASE}
.if exists(${LOCALBASE}/lib/libldap.so.1)
LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21-client
.endif
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
.endif
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 9dd2b76acffa..e2b3ee2aad2d 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -424,7 +424,7 @@ CONFIGURE_ARGS+=--with-ncurses=${NCURSESBASE}
.if exists(${LOCALBASE}/lib/libldap.so.1)
LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap21-client
.endif
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
.endif