aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-26 00:13:38 +0800
committermat <mat@FreeBSD.org>2016-04-26 00:13:38 +0800
commit249200c5ac5a6482e3f464dcbabf7f4879065734 (patch)
tree2cf1a158cf8540bcd6bed759d4e35240e31330bb /lang
parent4a29dd7050d143c963a767fa8b7671e3a0ddc09d (diff)
downloadfreebsd-ports-gnome-249200c5ac5a6482e3f464dcbabf7f4879065734.tar.gz
freebsd-ports-gnome-249200c5ac5a6482e3f464dcbabf7f4879065734.tar.zst
freebsd-ports-gnome-249200c5ac5a6482e3f464dcbabf7f4879065734.zip
Remove USE_SQLITE from bsd.databases.mk, replaced by USES=sqlite.
While there replace USE_SQLITE=x by USES=sqlite:x. PR: 208971 Submitted by: mat Exp-run by: antoine With hat: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D5951
Diffstat (limited to 'lang')
-rw-r--r--lang/bigloo/Makefile2
-rw-r--r--lang/io/Makefile.addons2
-rw-r--r--lang/munger/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/lang/bigloo/Makefile b/lang/bigloo/Makefile
index 51486acd24b3..025fb783d402 100644
--- a/lang/bigloo/Makefile
+++ b/lang/bigloo/Makefile
@@ -66,7 +66,7 @@ MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
MPG123_CONFIGURE_OFF= --disable-mpg123
OPENSSL_USE= OPENSSL=yes
OPENSSL_CONFIGURE_OFF= --disable-ssl
-SQLITE_USE= SQLITE=yes
+SQLITE_USES= sqlite
SQLITE_CONFIGURE_OFF= --disable-pkglib --disable-sqlite
.include <bsd.port.options.mk>
diff --git a/lang/io/Makefile.addons b/lang/io/Makefile.addons
index 85acc3fa6b9a..fa9d89496afb 100644
--- a/lang/io/Makefile.addons
+++ b/lang/io/Makefile.addons
@@ -94,7 +94,7 @@ Python_USES= python
QDBM_LIB_DEPENDS= libqdbm.so:databases/qdbm
ReadLine_USES= readline:port
Regex_LIB_DEPENDS= libpcre.so:devel/pcre
-SQLite3_USE= SQLITE=3
+SQLite3_USES= sqlite:3
SampleRateConverter_LIB_DEPENDS=\
libsamplerate.so:audio/libsamplerate
Socket_LIB_DEPENDS= libevent.so:devel/libevent2
diff --git a/lang/munger/Makefile b/lang/munger/Makefile
index 90633963a911..306c342ab94f 100644
--- a/lang/munger/Makefile
+++ b/lang/munger/Makefile
@@ -24,7 +24,7 @@ DATADIR= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= SQLITE
OPTIONS_DEFAULT= SQLITE
-SQLITE_USE= SQLITE=3
+SQLITE_USES= sqlite:3
SQLITE_MAKE_ARGS= -DWITH_SQL
post-patch: